Vulnerabilities > Denx

DATE CVE VULNERABILITY TITLE RISK
2021-02-17 CVE-2021-27138 Unspecified vulnerability in Denx U-Boot
The boot loader in Das U-Boot before 2021.04-rc2 mishandles use of unit addresses in a FIT.
network
denx
6.8
2021-02-17 CVE-2021-27097 Unspecified vulnerability in Denx U-Boot
The boot loader in Das U-Boot before 2021.04-rc2 mishandles a modified FIT.
network
denx
6.8
2020-03-19 CVE-2020-10648 Improper Input Validation vulnerability in multiple products
Das U-Boot through 2020.01 allows attackers to bypass verified boot restrictions and subsequently boot arbitrary images by providing a crafted FIT image to a system configured to boot the default configuration.
network
denx opensuse CWE-20
6.8
2020-01-29 CVE-2020-8432 Double Free vulnerability in multiple products
In Das U-Boot through 2020.01, a double free has been found in the cmd/gpt.c do_rename_gpt_parts() function.
network
low complexity
denx opensuse CWE-415
critical
10.0
2019-08-06 CVE-2019-13106 Out-of-bounds Write vulnerability in Denx U-Boot
Das U-Boot versions 2016.09 through 2019.07-rc4 can memset() too much data while reading a crafted ext4 filesystem, which results in a stack buffer overflow and likely code execution.
network
denx CWE-787
8.3
2019-08-06 CVE-2019-13105 Double Free vulnerability in Denx U-Boot 2019.07
Das U-Boot versions 2019.07-rc1 through 2019.07-rc4 can double-free a cached block of data when listing files in a crafted ext4 filesystem.
network
denx CWE-415
6.8
2019-08-06 CVE-2019-13104 Improper Restriction of Operations within the Bounds of a Memory Buffer vulnerability in Denx U-Boot
In Das U-Boot versions 2016.11-rc1 through 2019.07-rc4, an underflow can cause memcpy() to overwrite a very large amount of data (including the whole stack) while reading a crafted ext4 filesystem.
network
denx CWE-119
6.8
2019-07-31 CVE-2019-14204 Out-of-bounds Write vulnerability in Denx U-Boot
An issue was discovered in Das U-Boot through 2019.07.
network
low complexity
denx CWE-787
7.5
2019-07-31 CVE-2019-14203 Out-of-bounds Write vulnerability in Denx U-Boot
An issue was discovered in Das U-Boot through 2019.07.
network
low complexity
denx CWE-787
7.5
2019-07-31 CVE-2019-14202 Out-of-bounds Write vulnerability in Denx U-Boot
An issue was discovered in Das U-Boot through 2019.07.
network
low complexity
denx CWE-787
7.5