Vulnerabilities > Improper Input Validation

DATE CVE VULNERABILITY TITLE RISK
2024-05-15 CVE-2024-34098 Acrobat Reader versions 20.005.30574, 24.002.20736 and earlier are affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user.
local
low complexity
CWE-20
7.8
2024-05-14 CVE-2024-28135 A low privileged remote attacker can use a command injection vulnerability in the API which performs remote code execution as the user-app user due to improper input validation.
network
low complexity
CWE-20
5.0
2024-04-10 CVE-2024-20758 Adobe Commerce versions 2.4.6-p4, 2.4.5-p6, 2.4.4-p7, 2.4.7-beta3 and earlier are affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user.
network
high complexity
CWE-20
critical
9.0
2024-03-12 CVE-2024-25994 An unauthenticated remote attacker can upload a arbitrary script file due to improper input validation. The upload destination is fixed and is write only.
network
low complexity
CWE-20
5.3
2024-03-12 CVE-2024-25997 An unauthenticated remote attacker can perform a log injection due to improper input validation.
network
low complexity
CWE-20
5.3
2024-03-12 CVE-2024-25998 An unauthenticated remote attacker can perform a command injection in the OCPP Service with limited privileges due to improper input validation.
network
low complexity
CWE-20
7.3
2024-03-12 CVE-2024-26000 An unauthenticated remote attacker can read memory out of bounds due to improper input validation in the MQTT stack. The brute force attack is not always successful because of memory randomization. 
network
high complexity
CWE-20
5.9
2024-03-12 CVE-2024-26001 An unauthenticated remote attacker can write memory out of bounds due to improper input validation in the MQTT stack.
network
high complexity
CWE-20
7.4
2024-03-12 CVE-2024-26002 An improper input validation in the Qualcom plctool allows a local attacker with low privileges to gain root access by changing the ownership of specific files.
local
low complexity
CWE-20
7.8
2024-02-29 CVE-2023-44345 Adobe InDesign versions ID18.5 (and earlier) and ID17.4.2 (and earlier) are affected by a Improper Input Validation vulnerability.
local
low complexity
CWE-20
5.5