Vulnerabilities > Access of Resource Using Incompatible Type ('Type Confusion')

DATE CVE VULNERABILITY TITLE RISK
2021-04-30 CVE-2021-21230 Type Confusion vulnerability in Google Chrome
Type confusion in V8 in Google Chrome prior to 90.0.4430.93 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
network
google CWE-843
6.8
2021-04-26 CVE-2021-21224 Type Confusion vulnerability in multiple products
Type confusion in V8 in Google Chrome prior to 90.0.4430.85 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page.
6.8
2021-04-02 CVE-2021-1789 Type Confusion vulnerability in multiple products
A type confusion issue was addressed with improved state handling.
6.8
2021-02-26 CVE-2021-23954 Type Confusion vulnerability in Mozilla Firefox
Using the new logical assignment operators in a JavaScript switch statement could have caused a type confusion, leading to a memory corruption and a potentially exploitable crash.
network
mozilla CWE-843
6.8
2021-02-09 CVE-2020-27257 Type Confusion vulnerability in Omron products
This vulnerability allows local attackers to execute arbitrary code due to the lack of proper validation of user-supplied data, which can result in a type-confusion condition in the Omron CX-One Version 4.60 and prior devices.
network
omron CWE-843
6.8
2021-02-03 CVE-2021-0352 Type Confusion vulnerability in Google Android 10.0/11.0
In RT regmap driver, there is a possible memory corruption due to type confusion.
local
low complexity
google CWE-843
2.1
2021-01-26 CVE-2020-36229 Type Confusion vulnerability in multiple products
A flaw was discovered in ldap_X509dn2bv in OpenLDAP before 2.4.57 leading to a slapd crash in the X.509 DN parsing in ad_keystring, resulting in denial of service.
network
low complexity
openldap debian CWE-843
5.0
2021-01-18 CVE-2021-25177 Type Confusion vulnerability in multiple products
An issue was discovered in Open Design Alliance Drawings SDK before 2021.11.
6.8
2021-01-12 CVE-2020-26990 Type Confusion vulnerability in Siemens Jt2Go and Teamcenter Visualization
A vulnerability has been identified in JT2Go (All versions < V13.1.0.1), Teamcenter Visualization (All versions < V13.1.0.1).
network
siemens CWE-843
6.8
2021-01-12 CVE-2020-26980 Type Confusion vulnerability in Siemens Jt2Go and Teamcenter Visualization
A vulnerability has been identified in JT2Go (All versions < V13.1.0), Teamcenter Visualization (All versions < V13.1.0).
network
siemens CWE-843
6.8