Vulnerabilities > Sass Lang

DATE CVE VULNERABILITY TITLE RISK
2021-01-11 CVE-2020-24025 Improper Certificate Validation vulnerability in Sass-Lang Node-Sass
Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path.
network
low complexity
sass-lang CWE-295
5.0
2019-11-06 CVE-2019-18799 NULL Pointer Dereference vulnerability in Sass-Lang Libsass
LibSass before 3.6.3 allows a NULL pointer dereference in Sass::Parser::parseCompoundSelector in parser_selectors.cpp.
network
sass-lang CWE-476
4.3
2019-11-06 CVE-2019-18798 Out-of-bounds Read vulnerability in Sass-Lang Libsass
LibSass before 3.6.3 allows a heap-based buffer over-read in Sass::weaveParents in ast_sel_weave.cpp.
network
sass-lang CWE-125
4.3
2019-11-06 CVE-2019-18797 Uncontrolled Recursion vulnerability in Sass-Lang Libsass
LibSass 3.6.1 has uncontrolled recursion in Sass::Eval::operator()(Sass::Binary_Expression*) in eval.cpp.
network
sass-lang CWE-674
4.3
2019-04-23 CVE-2018-20822 Uncontrolled Recursion vulnerability in Sass-Lang Libsass 3.5.4
LibSass 3.5.4 allows attackers to cause a denial-of-service (uncontrolled recursion in Sass::Complex_Selector::perform in ast.hpp and Sass::Inspect::operator in inspect.cpp).
network
sass-lang CWE-674
4.3
2019-04-23 CVE-2018-20821 Uncontrolled Recursion vulnerability in Sass-Lang Libsass
The parsing component in LibSass through 3.5.5 allows attackers to cause a denial-of-service (uncontrolled recursion in Sass::Parser::parse_css_variable_value in parser.cpp).
network
sass-lang CWE-674
4.3
2019-01-14 CVE-2019-6286 Out-of-bounds Read vulnerability in Sass-Lang Libsass 3.5.5
In LibSass 3.5.5, a heap-based buffer over-read exists in Sass::Prelexer::skip_over_scopes in prelexer.hpp when called from Sass::Parser::parse_import(), a similar issue to CVE-2018-11693.
network
sass-lang CWE-125
4.3
2019-01-14 CVE-2019-6284 Out-of-bounds Read vulnerability in Sass-Lang Libsass 3.5.5
In LibSass 3.5.5, a heap-based buffer over-read exists in Sass::Prelexer::alternatives in prelexer.hpp.
network
sass-lang CWE-125
4.3
2019-01-14 CVE-2019-6283 Out-of-bounds Read vulnerability in Sass-Lang Libsass 3.5.5
In LibSass 3.5.5, a heap-based buffer over-read exists in Sass::Prelexer::parenthese_scope in prelexer.hpp.
network
sass-lang CWE-125
4.3
2018-12-17 CVE-2018-20190 NULL Pointer Dereference vulnerability in Sass-Lang Libsass 3.5.5
In LibSass 3.5.5, a NULL Pointer Dereference in the function Sass::Eval::operator()(Sass::Supports_Operator*) in eval.cpp may cause a Denial of Service (application crash) via a crafted sass input file.
network
sass-lang CWE-476
4.3