Vulnerabilities > Gitea

DATE CVE VULNERABILITY TITLE RISK
2022-05-03 CVE-2022-27313 Unspecified vulnerability in Gitea 1.16.3
An arbitrary file deletion vulnerability in Gitea v1.16.3 allows attackers to cause a Denial of Service (DoS) via deleting the configuration file.
network
low complexity
gitea
5.0
2022-03-24 CVE-2022-1058 Open Redirect vulnerability in Gitea
Open Redirect on login in GitHub repository go-gitea/gitea prior to 1.16.5.
network
gitea CWE-601
5.8
2022-03-15 CVE-2021-29134 Path Traversal vulnerability in Gitea
The avatar middleware in Gitea before 1.13.6 allows Directory Traversal via a crafted URL.
network
low complexity
gitea CWE-22
5.0
2022-03-10 CVE-2022-0905 Incorrect Authorization vulnerability in Gitea
Improper Authorization in GitHub repository go-gitea/gitea prior to 1.16.4.
network
low complexity
gitea CWE-863
5.5
2022-02-09 CVE-2021-45330 Improper Privilege Management vulnerability in Gitea
An issue exsits in Gitea through 1.15.7, which could let a malicious user gain privileges due to client side cookies not being deleted and the session remains valid on the server side for reuse.
network
low complexity
gitea CWE-269
7.5
2022-02-09 CVE-2021-45331 Improper Authentication vulnerability in Gitea
An Authentication Bypass vulnerability exists in Gitea before 1.5.0, which could let a malicious user gain privileges.
network
low complexity
gitea CWE-287
7.5
2022-02-08 CVE-2021-45329 Cross-site Scripting vulnerability in Gitea
Cross Site Scripting (XSS) vulnerability exists in Gitea before 1.5.1 via the repository settings inside the external wiki/issue tracker URL field.
network
gitea CWE-79
4.3
2022-02-08 CVE-2021-45328 Open Redirect vulnerability in Gitea
Gitea before 1.4.3 is affected by URL Redirection to Untrusted Site ('Open Redirect') via internal URLs.
network
gitea CWE-601
5.8
2022-02-08 CVE-2021-45325 Server-Side Request Forgery (SSRF) vulnerability in Gitea
Server Side Request Forgery (SSRF) vulneraility exists in Gitea before 1.7.0 using the OpenID URL.
network
low complexity
gitea CWE-918
5.0
2022-02-08 CVE-2021-45326 Cross-Site Request Forgery (CSRF) vulnerability in Gitea
Cross Site Request Forgery (CSRF) vulnerability exists in Gitea before 1.5.2 via API routes.This can be dangerous especially with state altering POST requests.
network
gitea CWE-352
6.8