Vulnerabilities > Expresstech

DATE CVE VULNERABILITY TITLE RISK
2024-07-11 CVE-2024-6025 Cross-site Scripting vulnerability in Expresstech Quiz and Survey Master
The Quiz and Survey Master (QSM) WordPress plugin before 9.0.5 does not sanitise and escape some of its Quiz settings, which could allow contributors and higher to perform Stored Cross-Site Scripting attacks
network
low complexity
expresstech CWE-79
5.4
2024-07-02 CVE-2024-5606 SQL Injection vulnerability in Expresstech Quiz and Survey Master
The Quiz and Survey Master (QSM) WordPress plugin before 9.0.2 is vulnerable does not validate and escape the question_id parameter in the qsm_bulk_delete_question_from_database AJAX action, leading to a SQL injection exploitable by Contributors and above role
network
low complexity
expresstech CWE-89
8.8
2023-11-13 CVE-2023-26524 Cross-Site Request Forgery (CSRF) vulnerability in Expresstech Quiz and Survey Master
Cross-Site Request Forgery (CSRF) vulnerability in ExpressTech Quiz And Survey Master – Best Quiz, Exam and Survey Plugin for WordPress plugin <= 8.0.10 versions.
network
low complexity
expresstech CWE-352
8.8
2023-08-07 CVE-2023-3575 Unspecified vulnerability in Expresstech Quiz and Survey Master
The Quiz And Survey Master WordPress plugin before 8.1.11 does not properly sanitize and escape question titles, which could allow users with the Contributor role and above to perform Stored Cross-Site Scripting attacks
network
low complexity
expresstech
5.4
2023-06-09 CVE-2023-0291 Unspecified vulnerability in Expresstech Quiz and Survey Master
The Quiz And Survey Master for WordPress is vulnerable to authorization bypass due to a missing capability check on the function associated with the qsm_remove_file_fd_question AJAX action in versions up to, and including, 8.0.8.
network
low complexity
expresstech
critical
9.1
2023-06-09 CVE-2023-0292 Unspecified vulnerability in Expresstech Quiz and Survey Master
The Quiz And Survey Master plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 8.0.8.
network
low complexity
expresstech
8.1
2023-02-14 CVE-2022-46862 Cross-Site Request Forgery (CSRF) vulnerability in Expresstech Quiz and Survey Master
Cross-Site Request Forgery (CSRF) vulnerability in ExpressTech Quiz And Survey Master – Best Quiz, Exam and Survey Plugin for WordPress plugin <= 8.0.7 versions.
network
low complexity
expresstech CWE-352
8.8
2022-11-29 CVE-2022-4032 Cross-site Scripting vulnerability in Expresstech Quiz and Survey Master
The Quiz and Survey Master plugin for WordPress is vulnerable to iFrame Injection via the 'question[id]' parameter in versions up to, and including, 8.0.4 due to insufficient input sanitization and output escaping that allowed iframe tags to be injected.
network
low complexity
expresstech CWE-79
6.1
2022-11-29 CVE-2022-4033 Improper Input Validation vulnerability in Expresstech Quiz and Survey Master
The Quiz and Survey Master plugin for WordPress is vulnerable to input validation bypass via the 'question[id]' parameter in versions up to, and including, 8.0.4 due to insufficient input validation that allows attackers to inject content other than the specified value (i.e.
network
low complexity
expresstech CWE-20
5.3
2022-11-18 CVE-2022-40698 Cross-site Scripting vulnerability in Expresstech Quiz and Survey Master
Auth.
network
low complexity
expresstech CWE-79
6.1