Vulnerabilities > Codeigniter

DATE CVE VULNERABILITY TITLE RISK
2022-02-28 CVE-2022-24711 Code Injection vulnerability in Codeigniter
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework.
network
low complexity
codeigniter CWE-94
7.5
2022-02-28 CVE-2022-24712 Cross-Site Request Forgery (CSRF) vulnerability in Codeigniter
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework.
6.8
2022-01-24 CVE-2022-21715 Cross-site Scripting vulnerability in Codeigniter
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework.
4.3
2022-01-04 CVE-2022-21647 Deserialization of Untrusted Data vulnerability in Codeigniter
CodeIgniter is an open source PHP full-stack web framework.
network
low complexity
codeigniter CWE-502
7.5
2020-03-23 CVE-2020-10793 Improper Privilege Management vulnerability in Codeigniter
CodeIgniter through 4.0.0 allows remote attackers to gain privileges via a modified Email ID to the "Select Role of the User" page.
network
low complexity
codeigniter CWE-269
6.5
2020-01-09 CVE-2012-1915 Cross-site Scripting vulnerability in Codeigniter
EllisLab CodeIgniter 2.1.2 allows remote attackers to bypass the xss_clean() Filter and perform XSS attacks.
4.3
2018-06-17 CVE-2018-12071 Session Fixation vulnerability in Codeigniter
A Session Fixation issue exists in CodeIgniter before 3.1.9 because session.use_strict_mode in the Session Library was mishandled.
network
low complexity
codeigniter CWE-384
7.5
2018-02-21 CVE-2015-5725 SQL Injection vulnerability in Codeigniter
SQL injection vulnerability in the offset method in the Active Record class in CodeIgniter before 2.2.4 allows remote attackers to execute arbitrary SQL commands via vectors involving the offset variable.
network
low complexity
codeigniter CWE-89
7.5
2018-02-21 CVE-2013-4891 Cross-site Scripting vulnerability in Codeigniter
The xss_clean function in CodeIgniter before 2.1.4 might allow remote attackers to bypass an intended protection mechanism and conduct cross-site scripting (XSS) attacks via an unclosed HTML tag.
4.3
2017-11-17 CVE-2017-1000247 Improper Input Validation vulnerability in Codeigniter 3.1.3
British Columbia Institute of Technology CodeIgniter 3.1.3 is vulnerable to HTTP Header Injection in the set_status_header() common function under Apache resulting in HTTP Header Injection flaws.
network
low complexity
codeigniter CWE-20
5.0