Vulnerabilities > Access of Resource Using Incompatible Type ('Type Confusion')

DATE CVE VULNERABILITY TITLE RISK
2019-04-09 CVE-2019-0810 Type Confusion vulnerability in Microsoft Chakracore and Edge
A remote code execution vulnerability exists in the way that the Chakra scripting engine handles objects in memory in Microsoft Edge, aka 'Chakra Scripting Engine Memory Corruption Vulnerability'.
network
high complexity
microsoft CWE-843
7.5
2019-04-09 CVE-2019-0752 Type Confusion vulnerability in Microsoft Internet Explorer 10/11
A remote code execution vulnerability exists in the way that the scripting engine handles objects in memory in Internet Explorer, aka 'Scripting Engine Memory Corruption Vulnerability'.
network
high complexity
microsoft CWE-843
7.5
2019-03-27 CVE-2019-10231 Type Confusion vulnerability in Teclib-Edition Gestionnaire Libre DE Parc Informatique
Teclib GLPI before 9.4.1.1 is affected by a PHP type juggling vulnerability allowing bypass of authentication.
network
low complexity
teclib-edition CWE-843
7.5
2019-03-05 CVE-2019-6215 Type Confusion vulnerability in multiple products
A type confusion issue was addressed with improved memory handling.
6.8
2019-03-05 CVE-2019-6214 Type Confusion vulnerability in Apple products
A type confusion issue was addressed with improved memory handling.
network
apple CWE-843
6.8
2018-08-15 CVE-2018-8384 Type Confusion vulnerability in Microsoft Chakracore
A remote code execution vulnerability exists in the way that the Chakra scripting engine handles objects in memory in Microsoft Edge, aka "Chakra Scripting Engine Memory Corruption Vulnerability." This affects ChakraCore.
network
high complexity
microsoft CWE-843
7.6
2018-07-11 CVE-2018-8298 Type Confusion vulnerability in Microsoft Chakracore
A remote code execution vulnerability exists in the way that the ChakraCore scripting engine handles objects in memory, aka "Scripting Engine Memory Corruption Vulnerability." This affects ChakraCore.
network
high complexity
microsoft CWE-843
7.6
2018-07-11 CVE-2018-8291 Type Confusion vulnerability in Microsoft Chakracore, Edge and Internet Explorer
A remote code execution vulnerability exists in the way the scripting engine handles objects in memory in Microsoft browsers, aka "Scripting Engine Memory Corruption Vulnerability." This affects ChakraCore, Internet Explorer 11, Microsoft Edge.
network
high complexity
microsoft CWE-843
7.6
2018-07-11 CVE-2018-8279 Type Confusion vulnerability in Microsoft Chakracore and Edge
A remote code execution vulnerability exists when Microsoft Edge improperly accesses objects in memory, aka "Microsoft Edge Memory Corruption Vulnerability." This affects Microsoft Edge, ChakraCore.
network
high complexity
microsoft CWE-843
7.6
2018-06-14 CVE-2018-8229 Type Confusion vulnerability in Microsoft Chakracore and Edge
A remote code execution vulnerability exists in the way that the Chakra scripting engine handles objects in memory in Microsoft Edge, aka "Chakra Scripting Engine Memory Corruption Vulnerability." This affects Microsoft Edge, ChakraCore.
network
high complexity
microsoft CWE-843
7.6