Vulnerabilities > Blackberry

DATE CVE VULNERABILITY TITLE RISK
2022-03-10 CVE-2021-32025 Improper Privilege Management vulnerability in Blackberry products
An elevation of privilege vulnerability in the QNX Neutrino Kernel of affected versions of QNX Software Development Platform version(s) 6.4.0 to 7.0, QNX Momentics all 6.3.x versions, QNX OS for Safety versions 1.0.0 to 1.0.2, QNX OS for Safety versions 2.0.0 to 2.0.1, QNX for Medical versions 1.0.0 to 1.1.1, and QNX OS for Medical version 2.0.0 could allow an attacker to potentially access data, modify behavior, or permanently crash the system.
local
low complexity
blackberry CWE-269
7.2
2021-12-13 CVE-2021-32024 Unspecified vulnerability in Blackberry QNX Software Development Platform
A remote code execution vulnerability in the BMP image codec of BlackBerry QNX SDP version(s) 6.4 to 7.1 could allow an attacker to potentially execute code in the context of the affected process.
network
low complexity
blackberry
7.5
2021-11-10 CVE-2021-32021 Unspecified vulnerability in Blackberry Protect 1574
A denial of service vulnerability in the message broker of BlackBerry Protect for Windows version(s) versions 1574 and earlier could allow an attacker to potentially execute code in the context of a BlackBerry Cylance service that has admin rights on the system.
local
low complexity
blackberry
7.2
2021-11-10 CVE-2021-32022 Unspecified vulnerability in Blackberry Protect 1574
A low privileged delete vulnerability using CEF RPC server of BlackBerry Protect for Windows version(s) versions 1574 and earlier could allow an attacker to potentially execute code in the context of a BlackBerry Cylance service that has admin rights on the system and gaining the ability to delete data from the local system.
local
low complexity
blackberry
2.1
2021-11-10 CVE-2021-32023 Improper Privilege Management vulnerability in Blackberry Protect 1574
An elevation of privilege vulnerability in the message broker of BlackBerry Protect for Windows version(s) versions 1574 and earlier could allow an attacker to potentially execute code in the context of a BlackBerry Cylance service that has admin rights on the system.
local
low complexity
blackberry CWE-269
7.2
2021-08-17 CVE-2021-22156 Integer Overflow or Wraparound vulnerability in Blackberry products
An integer overflow vulnerability in the calloc() function of the C runtime library of affected versions of BlackBerry® QNX Software Development Platform (SDP) version(s) 6.5.0SP1 and earlier, QNX OS for Medical 1.1 and earlier, and QNX OS for Safety 1.0.1 and earlier that could allow an attacker to potentially perform a denial of service or execute arbitrary code.
6.8
2021-05-13 CVE-2021-22152 Improper Input Validation vulnerability in Blackberry Unified Endpoint Management
A Denial of Service due to Improper Input Validation vulnerability in the Management Console component of BlackBerry UEM version(s) 12.13.1 QF2 and earlier and 12.12.1a QF6 and earlier could allow an attacker to potentially to prevent any new user connections.
local
low complexity
blackberry CWE-20
2.1
2021-05-13 CVE-2021-22153 Improper Neutralization of Formula Elements in a CSV File vulnerability in Blackberry Unified Endpoint Management
A Remote Code Execution vulnerability in the Management Console component of BlackBerry UEM version(s) 12.13.1 QF2 and earlier and 12.12.1a QF6 and earlier could allow an attacker to potentially cause the spreadsheet application to run commands on the victim’s local machine with the authority of the user.
6.0
2021-05-13 CVE-2021-22154 Information Exposure vulnerability in Blackberry Unified Endpoint Management
An Information Disclosure vulnerability in the Management Console component of BlackBerry UEM version(s) 12.13.1 QF2 and earlier and 12.12.1a QF6 and earlier could allow an attacker to potentially gain access to a victim's web history.
network
low complexity
blackberry CWE-200
5.0
2021-05-13 CVE-2021-22155 Incorrect Authorization vulnerability in Blackberry Workspaces Server
An Authentication Bypass vulnerability in the SAML Authentication component of BlackBerry Workspaces Server (deployed with Appliance-X) version(s) 10.1, 9.1 and earlier could allow an attacker to potentially gain access to the application in the context of the targeted user’s account.
network
low complexity
blackberry CWE-863
6.5