CVE-2007-6655 - Code Injection vulnerability in Matpo Bilder Galerie Kontakt Formular 1.4

Publication

2008-01-04

Last modification

2017-09-29

Summary

PHP remote file inclusion vulnerability in includes/function.php in Kontakt Formular 1.4 allows remote attackers to execute arbitrary PHP code via a URL in the root_path parameter.

Description

Kontakt Formular is prone to a remote file-include vulnerability because it fails to sufficiently sanitize user-supplied data.Exploiting this issue may allow an attacker to compromise the application and the underlying system; other attacks are also possible.This issue affects Kontakt Formular 1.4; other versions may be vulnerable as well.

Solution

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: info@vumetric.com.

Exploit

An attacker can exploit this issue via a browser.The following proof-of-concept URI is available:http://www.example.com/[path]/includes/function.php?root_path=[Shellcode]

Classification

CWE-94 - Code Injection

Risk level (CVSS AV:N/AC:L/Au:N/C:P/I:P/A:P)

High

7.5

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

Vendor Product Versions
Matpo Bilder Galerie Kontakt Formular  1.4