Weekly Vulnerabilities Reports > January 19 to 25, 2004

Overview

30 new vulnerabilities reported during this period, including 3 critical vulnerabilities and 12 high severity vulnerabilities. This weekly summary report vulnerabilities in 41 products from 19 vendors including Microsoft, IBM, Phpgedview, Cisco, and Debian. Vulnerabilities are notably categorized as "Resource Management Errors", "Permissions, Privileges, and Access Controls", "Information Exposure", "Improper Input Validation", and "Improper Authentication".

  • 27 reported vulnerabilities are remotely exploitables.
  • 1 reported vulnerabilities are related to weaknesses in OWASP Top Ten.
  • 29 reported vulnerabilities are exploitable by an anonymous user.
  • Microsoft has the most reported vulnerabilities, with 5 reported vulnerabilities.
  • Microsoft has the most reported critical vulnerabilities, with 2 reported vulnerabilities.

TOTAL
VULNERABILITIES
CRITICAL RISK
VULNERABILITIES
HIGH RISK
VULNERABILITIES
MEDIUM RISK
VULNERABILITIES
LOW RISK
VULNERABILITIES
REMOTELY
EXPLOITABLE
LOCALLY
EXPLOITABLE
EXPLOIT
AVAILABLE
EXPLOITABLE
ANONYMOUSLY
AFFECTING
WEB APPLICATION

Vulnerability Details

The following table list reported vulnerabilities for the period covered by this report:

Expand/Hide

3 Critical Vulnerabilities

DATE CVE VENDOR VULNERABILITY CVSS
2004-01-21 CVE-2004-1760 Cisco
IBM
Improper Authentication vulnerability in multiple products

The default installation of Cisco voice products, when running the IBM Director Agent on IBM servers before OS 2000.2.6, does not require authentication, which allows remote attackers to gain administrator privileges by connecting to TCP port 14247.

10.0
2004-01-20 CVE-2003-1027 Microsoft Unspecified vulnerability in Microsoft IE and Internet Explorer

Internet Explorer 5.01 through 6 SP1 allows remote attackers to direct drag and drop behaviors and other mouse click actions to other windows by using method caching (SaveRef) to access the window.moveBy method, which is otherwise inaccessible, as demonstrated by HijackClickV2, a different vulnerability than CVE-2003-0823, aka the "Function Pointer Drag and Drop Vulnerability."

10.0
2004-01-20 CVE-2003-1026 Microsoft Permissions, Privileges, and Access Controls vulnerability in Microsoft IE and Internet Explorer

Internet Explorer 5.01 through 6 SP1 allows remote attackers to bypass zone restrictions via a javascript protocol URL in a sub-frame, which is added to the history list and executed in the top window's zone when the history.back (back) function is called, as demonstrated by BackToFramedJpu, aka the "Travel Log Cross Domain Vulnerability."

9.3

12 High Vulnerabilities

DATE CVE VENDOR VULNERABILITY CVSS
2004-01-20 CVE-2004-0037 Opentext Local File Reference Command Execution vulnerability in Opentext Firstclass Desktop Client 7.1

FirstClass Desktop Client 7.1 allows remote attackers to execute arbitrary commands via hyperlinks in FirstClass RTF messages.

7.5
2004-01-20 CVE-2004-0035 Phorum SQL Injection vulnerability in Phorum Registration Script hide_email

SQL injection vulnerability in register.php for Phorum 3.4.5 and earlier allows remote attackers to execute arbitrary SQL commands via the hide_email parameter.

7.5
2004-01-20 CVE-2004-0031 Phpgedview Denial-Of-Service vulnerability in PHPgedview 2.61

PHPGEDVIEW 2.61 allows remote attackers to reinstall the software and change the administrator password via a direct HTTP request to editconfig.php.

7.5
2004-01-20 CVE-2004-0030 Phpgedview PHP Remote File Include vulnerability in PHPgedview 2.61

PHP remote file inclusion vulnerability in (1) functions.php, (2) authentication_index.php, and (3) config_gedcom.php for PHPGEDVIEW 2.61 allows remote attackers to execute arbitrary PHP code by modifying the PGV_BASE_DIRECTORY parameter to reference a URL on a remote web server that contains the code.

7.5
2004-01-20 CVE-2004-0014 ND Buffer Overrun vulnerability in nd

Multiple buffer overflows in the nd WebDAV interface 0.8.2 and earlier allows remote web servers to execute arbitrary code via certain long strings.

7.5
2004-01-20 CVE-2004-0011 Debian Unspecified vulnerability in Debian FSP 2.81.B18

Buffer overflow in fsp before 2.81.b18 allows remote users to execute arbitrary code.

7.5
2004-01-20 CVE-2003-1023 Midnight Commander Buffer Overflow vulnerability in Midnight Commander Midnight Commander 4.5.52/4.5.55/4.6

Stack-based buffer overflow in vfs_s_resolve_symlink of vfs/direntry.c for Midnight Commander (mc) 4.6.0 and earlier, and possibly later versions, allows remote attackers to execute arbitrary code during symlink conversion.

7.5
2004-01-20 CVE-2003-1022 Debian Unspecified vulnerability in Debian FSP 2.81.B18

Directory traversal vulnerability in fsp before 2.81.b18 allows remote users to access files outside the FSP root directory.

7.5
2004-01-20 CVE-2003-0990 Squirrelmail Remote Command Execution vulnerability in Squirrelmail G/PGP Encryption Plugin

The parseAddress code in (1) SquirrelMail 1.4.0 and (2) GPG Plugin 1.1 allows remote attackers to execute commands via shell metacharacters in the "To:" field.

7.5
2004-01-20 CVE-2003-0969 Mpg321 Remote Format String vulnerability in Mpg321 0.2.10

mpg321 0.2.10 allows remote attackers to overwrite memory and possibly execute arbitrary code via an mp3 file that passes certain strings to the printf function, possibly triggering a format string vulnerability.

7.5
2004-01-20 CVE-2003-1024 SUN Privilege Escalation vulnerability in SUN Sunos 5.8

Unknown vulnerability in the ls-F builtin function in tcsh on Solaris 8 allows local users to create or delete files as other users, and gain privileges.

7.2
2004-01-20 CVE-2003-0985 Linux Unspecified vulnerability in Linux Kernel

The mremap system call (do_mremap) in Linux kernel 2.4.x before 2.4.21, and possibly other versions before 2.4.24, does not properly perform bounds checks, which allows local users to cause a denial of service and possibly gain privileges by causing a remapping of a virtual memory area (VMA) to create a zero length VMA, a different vulnerability than CAN-2004-0077.

7.2

15 Medium Vulnerabilities

DATE CVE VENDOR VULNERABILITY CVSS
2004-01-20 CVE-2004-0032 Phpgedview Cross-Site Scripting vulnerability in PHPgedview 2.61

Cross-site scripting (XSS) vulnerability in search.php in PHPGEDVIEW 2.61 allows remote attackers to inject arbitrary HTML and web script via the firstname parameter.

6.8
2004-01-20 CVE-2003-0904 Microsoft Information Exposure vulnerability in Microsoft products

Microsoft Exchange 2003 and Outlook Web Access (OWA), when configured to use NTLM authentication, does not properly reuse HTTP connections, which can cause OWA users to view mailboxes of other users when Kerberos has been disabled as an authentication method for IIS 6.0, e.g.

6.0
2004-01-24 CVE-2004-2117 Tinyserver Multiple vulnerability in Tinyserver 1.1

Tiny Server 1.1 allows remote attackers to cause a denial of service (crash) via malformed HTTP requests such as (1) a GET request without the HTTP version (HTTP/1.1), or (2) a request without GET or the HTTP version.

5.0
2004-01-23 CVE-2004-2120 Reptile WEB Server Remote Denial Of Service vulnerability in Reptile web Server Reptile web Server 20020105

Reptile Web Server allows remote attackers to cause a denial of service (CPU consumption) via multiple incomplete GET requests without the HTTP version.

5.0
2004-01-21 CVE-2004-1759 Cisco
IBM
Resource Management Errors vulnerability in multiple products

Cisco voice products, when running the IBM Director Agent on IBM servers before OS 2000.2.6, allows remote attackers to cause a denial of service (CPU consumption) via arbitrary packets to TCP port 14247, as demonstrated using port scanning.

5.0
2004-01-20 CVE-2004-2127 Leif M Wright Unspecified vulnerability in Leif M. Wright web Blog 1.1

Directory traversal vulnerability in Web Blog 1.1 allows remote attackers to read arbitrary files via a ..

5.0
2004-01-20 CVE-2004-1766 Juniper Remote Communication vulnerability in NetScreen Security Manager Insecure Default

The default installation of NetScreen-Security Manager before Feature Pack 1 does not enable encryption for communication with devices running ScreenOS 5.0, which allows remote attackers to obtain sensitive information via sniffing.

5.0
2004-01-20 CVE-2004-0036 Jelsoft SQL Injection vulnerability in Jelsoft Vbulletin 2.3.0

SQL injection vulnerability in calendar.php for vBulletin Forum 2.3.x before 2.3.4 allows remote attackers to steal sensitive information via the eventid parameter.

5.0
2004-01-20 CVE-2004-0033 Phpgedview Unspecified vulnerability in PHPgedview 2.61

admin.php in PHPGEDVIEW 2.61 allows remote attackers to obtain sensitive information via an action parameter with a phpinfo command.

5.0
2004-01-20 CVE-2003-1028 Microsoft Unspecified vulnerability in Microsoft IE and Internet Explorer

The download function of Internet Explorer 6 SP1 allows remote attackers to obtain the cache directory name via an HTTP response with an invalid ContentType and a .htm file, which could allow remote attackers to bypass security mechanisms that rely on random names, as demonstrated by threadid10008.

5.0
2004-01-20 CVE-2003-0696 IBM Unspecified vulnerability in IBM AIX 5.1/5.2

The getipnodebyname() API in AIX 5.1 and 5.2 does not properly close sockets, which allows attackers to cause a denial of service (resource exhaustion).

5.0
2004-01-20 CVE-2004-0029 IBM Unspecified vulnerability in IBM Lotus Domino 6.0.2

Lotus Notes Domino 6.0.2 on Linux installs the notes.ini configuration file with world-writable permissions, which allows local users to modify the Notes configuration and gain privileges.

4.6
2004-01-24 CVE-2004-2122 Intra Forum Cross-Site Scripting vulnerability in Intra Forum

Cross-site scripting (XSS) vulnerability in intraforum_db.cgi in Intra Forum allows remote attackers to inject arbitrary web script or HTML via the (1) use_last_read or (2) forum parameters.

4.3
2004-01-20 CVE-2004-0034 Phorum Cross-Site Scripting/HTML Injection vulnerability in Phorum

Multiple cross-site scripting (XSS) vulnerabilities in Phorum 3.4.5 and earlier allow remote attackers to inject arbitrary HTML or web script via (1) the phorum_check_xss function in common.php, (2) the EditError variable in profile.php, and (3) the Error variable in login.php.

4.3
2004-01-20 CVE-2003-1025 Microsoft Improper Input Validation vulnerability in Microsoft Internet Explorer 6.0

Internet Explorer 5.01 through 6 SP1 allows remote attackers to spoof the domain of a URL via a "%01" character before an @ sign in the user@domain portion of the URL, which hides the rest of the URL, including the real site, in the address bar, aka the "Improper URL Canonicalization Vulnerability."

4.3

0 Low Vulnerabilities

DATE CVE VENDOR VULNERABILITY CVSS