Vulnerabilities > Apple > Medium

DATE CVE VULNERABILITY TITLE RISK
2022-06-16 CVE-2022-1642 Incorrect Type Conversion or Cast vulnerability in Apple Swift
A program using swift-corelibs-foundation is vulnerable to a denial of service attack caused by a potentially malicious source producing a JSON document containing a type mismatch.
network
low complexity
apple CWE-704
5.0
2022-05-26 CVE-2022-26743 Out-of-bounds Write vulnerability in Apple Macos
An out-of-bounds write issue was addressed with improved bounds checking.
local
apple CWE-787
6.9
2022-05-26 CVE-2022-26745 Out-of-bounds Write vulnerability in Apple Macos
A memory corruption issue was addressed with improved validation.
network
apple CWE-787
4.3
2022-05-26 CVE-2022-26746 Unspecified vulnerability in Apple mac OS X
This issue was addressed by removing the vulnerable code.
network
apple
4.3
2022-05-26 CVE-2022-26747 Unspecified vulnerability in Apple Xcode
This issue was addressed with improved checks.
network
apple
6.8
2022-05-26 CVE-2022-26748 Out-of-bounds Write vulnerability in Apple mac OS X
An out-of-bounds write issue was addressed with improved input validation.
network
apple CWE-787
6.8
2022-05-26 CVE-2022-26751 Out-of-bounds Write vulnerability in Apple products
A memory corruption issue was addressed with improved input validation.
network
apple CWE-787
6.8
2022-05-26 CVE-2022-26755 Unspecified vulnerability in Apple mac OS X
This issue was addressed with improved environment sanitization.
network
apple
4.3
2022-05-26 CVE-2022-26766 Improper Certificate Validation vulnerability in Apple products
A certificate parsing issue was addressed with improved checks.
network
apple CWE-295
4.3
2022-05-26 CVE-2022-26767 Incorrect Authorization vulnerability in Apple Macos
The issue was addressed with additional permissions checks.
network
apple CWE-863
4.3