CVE-2019-9712 - Cross-Site Scripting (XSS) vulnerability in Joomla Joomla!

Publication

2019-03-12

Last modification

2019-03-15

Summary

An issue was discovered in Joomla! before 3.9.4. The JSON handler in com_config lacks input validation, leading to XSS.

Description

Joomla! Core is prone to a cross-site scripting vulnerability because it fails to sanitize user-supplied input. An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and launch other attacks. Joomla! 3.2.0 through 3.9.3 are vulnerable.

Solution

Updates are available. Please see the references or vendor advisory for more information.

Exploit

An attacker can exploit this issue by enticing an unsuspecting user to visit a specially crafted URL.

Classification

CWE-79 - Cross-Site Scripting (XSS)

Risk level (CVSS AV:N/AC:M/Au:N/C:N/I:P/A:N)

Medium

4.3

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products