CVE-2019-6264 - Cross-Site Scripting (XSS) vulnerability in Joomla Joomla!

Publication

2019-01-16

Last modification

2019-02-26

Summary

An issue was discovered in Joomla! before 3.9.2. Inadequate escaping in mod_banners leads to a stored XSS vulnerability.

Description

Joomla! Core is prone to multiple HTML injection vulnerabilities. Successful exploits will allow attacker-supplied HTML and script code to run in the context of the affected browser, potentially allowing the attacker to steal cookie-based authentication credentials or to control how the site is rendered to the user. Other attacks are also possible. Joomla! CMS 2.5.0 through 3.9.1 are vulnerable.

Solution

Updates are available. Please see the references or vendor advisory for more information.

Exploit

Currently, we are not aware of any working exploits.

Classification

CWE-79 - Cross-Site Scripting (XSS)

Risk level (CVSS AV:N/AC:M/Au:N/C:N/I:P/A:N)

Medium

4.3

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None