\ CVE-2018-3953 - OS Command Injections vulnerability in Linksys E1200 Firmware and E2500 Firmware | Vumetric Cyber Portal

CVE-2018-3953 - OS Command Injections vulnerability in Linksys E1200 Firmware and E2500 Firmware

Publication

2018-10-17

Last modification

2019-01-23

Summary

Devices in the Linksys ESeries line of routers (Linksys E1200 Firmware Version 2.0.09 and Linksys E2500 Firmware Version 3.0.04) are susceptible to OS command injection vulnerabilities due to improper filtering of data passed to and retrieved from NVRAM. Data entered into the 'Router Name' input field through the web portal is submitted to apply.cgi as the value to the 'machine_name' POST parameter. When the 'preinit' binary receives the SIGHUP signal, it enters a code path that continues until it reaches offset 0x0042B5C4 in the 'start_lltd' function. Within the 'start_lltd' function, a 'nvram_get' call is used to obtain the value of the user-controlled 'machine_name' NVRAM entry. This value is then entered directly into a command intended to write the host name to a file and subsequently executed.

Classification

CWE-78 - OS Command Injections

Risk level (CVSS AV:N/AC:L/Au:S/C:C/I:C/A:C)

High

9

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products