Weekly Vulnerabilities Reports > January 15 to 21, 2001

Overview

9 new vulnerabilities reported during this period, including 0 critical vulnerabilities and 4 high severity vulnerabilities. This weekly summary report vulnerabilities in 4 products from 4 vendors including SSH, Oracle, AOL, and Dallas Semiconductor. Vulnerabilities are notably categorized as and "Cryptographic Issues".

  • 7 reported vulnerabilities are remotely exploitables.
  • 9 reported vulnerabilities are exploitable by an anonymous user.
  • SSH has the most reported vulnerabilities, with 6 reported vulnerabilities.

TOTAL
VULNERABILITIES
CRITICAL RISK
VULNERABILITIES
HIGH RISK
VULNERABILITIES
MEDIUM RISK
VULNERABILITIES
LOW RISK
VULNERABILITIES
REMOTELY
EXPLOITABLE
LOCALLY
EXPLOITABLE
EXPLOIT
AVAILABLE
EXPLOITABLE
ANONYMOUSLY
AFFECTING
WEB APPLICATION

Vulnerability Details

The following table list reported vulnerabilities for the period covered by this report:

0 Critical Vulnerabilities

DATE CVE VENDOR VULNERABILITY CVSS

4 High Vulnerabilities

DATE CVE VENDOR VULNERABILITY CVSS
2001-01-18 CVE-2001-1476 SSH Unspecified vulnerability in SSH

SSH before 2.0, with RC4 encryption and the "disallow NULL passwords" option enabled, makes it easier for remote attackers to guess portions of user passwords by replaying user sessions with certain modifications, which trigger different messages depending on whether the guess is correct or not.

7.5
2001-01-18 CVE-2001-1475 SSH Unspecified vulnerability in SSH

SSH before 2.0, when using RC4 and password authentication, allows remote attackers to replay messages until a new server key (VK) is generated.

7.5
2001-01-18 CVE-2001-1473 SSH Cryptographic Issues vulnerability in SSH

The SSH-1 protocol allows remote servers to conduct man-in-the-middle attacks and replay a client challenge response to a target server by creating a Session ID that matches the Session ID of the target, but which uses a public key pair that is weaker than the target's public key, which allows the attacker to compute the corresponding private key and use the target's Session ID with the compromised key pair to masquerade as the target.

7.5
2001-01-19 CVE-2001-1275 Oracle Unspecified vulnerability in Oracle Mysql

MySQL before 3.23.31 allows users with a MySQL account to use the SHOW GRANTS command to obtain the encrypted administrator password from the mysql.user table and possibly gain privileges via password cracking.

7.2

5 Medium Vulnerabilities

DATE CVE VENDOR VULNERABILITY CVSS
2001-01-18 CVE-2001-1416 AOL Unspecified vulnerability in AOL Instant Messenger 4.4A

Multiple cross-site scripting (XSS) vulnerabilities in the log messages in certain Alpha versions of AOL Instant Messenger (AIM) 4.4 allow remote attackers to execute arbitrary web script or HTML via an image in the (1) DATA, (2) STYLE, or (3) BINARY tags.

5.1
2001-01-18 CVE-2001-1474 SSH Remote Security vulnerability in SSH

SSH before 2.0 disables host key checking when connecting to the localhost, which allows remote attackers to silently redirect connections to the localhost by poisoning the client's DNS cache.

5.0
2001-01-18 CVE-2001-1470 SSH Unspecified vulnerability in SSH

The IDEA cipher as implemented by SSH1 does not protect the final block of a message against modification, which allows remote attackers to modify the block without detection by changing its cyclic redundancy check (CRC) to match the modifications to the message.

5.0
2001-01-18 CVE-2001-1469 SSH Unspecified vulnerability in SSH

The RC4 stream cipher as used by SSH1 allows remote attackers to modify messages without detection by XORing the original message's cyclic redundancy check (CRC) with the CRC of a mask consisting of all the bits of the original message that were modified.

5.0
2001-01-18 CVE-2001-1436 Dallas Semiconductor Unspecified vulnerability in Dallas Semiconductor Ibutton Ds1991

Dallas Semiconductor iButton DS1991 returns predictable values when given an incorrect password, which makes it easier for users with physical access to conduct dictionary attacks against the device password.

4.6

0 Low Vulnerabilities

DATE CVE VENDOR VULNERABILITY CVSS