Latest Wordpress Wordpress 4 6 8 Security Vulnerabilities

DATE CVE VULNERABILITY TITLE RISK
2019-12-27 CVE-2019-20043 Improper Privilege Management vulnerability in Wordpress
In in wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php in WordPress 3.7 to 5.3.0, authenticated users who do not have the rights to publish a post are able to mark posts as sticky or unsticky via the REST API.
network
low complexity
wordpress
CWE-269
nessus
5.0
2019-12-27 CVE-2019-20042 Cross-Site Scripting vulnerability in Wordpress
In wp-includes/formatting.php in WordPress 3.7 to 5.3.0, the function wp_targeted_link_rel() can be used in a particular way to result in a stored cross-site scripting (XSS) vulnerability.
network
wordpress
CWE-79
nessus
4.3
2019-12-27 CVE-2019-20041 Improper Input Validation vulnerability in Wordpress
wp_kses_bad_protocol in wp-includes/kses.php in WordPress before 5.3.1 mishandles the HTML5 colon named entity, allowing attackers to bypass input sanitization, as demonstrated by the javascript: substring.
network
low complexity
wordpress
CWE-20
nessus
7.5
2019-12-26 CVE-2019-16781 Cross-Site Scripting vulnerability in Wordpress
In WordPress before 5.3.1, authenticated users with lower privileges (like contributors) can inject JavaScript code in the block editor, which is executed within the dashboard.
network
wordpress
CWE-79
nessus
3.5
2019-12-26 CVE-2019-16780 Cross-Site Scripting vulnerability in Wordpress
WordPress users with lower privileges (like contributors) can inject JavaScript code in the block editor using a specific payload, which is executed within the dashboard.
network
wordpress
CWE-79
nessus
3.5
2019-10-17 CVE-2019-17675 Cross-Site Request Forgery (CSRF) vulnerability in Wordpress
WordPress before 5.2.4 does not properly consider type confusion during validation of the referer in the admin pages, possibly leading to CSRF.
network
wordpress
CWE-352
nessus
6.8
2019-10-17 CVE-2019-17674 Cross-Site Scripting vulnerability in Wordpress
WordPress before 5.2.4 is vulnerable to stored XSS (cross-site scripting) via the Customizer.
network
wordpress
CWE-79
nessus
3.5
2019-10-17 CVE-2019-17673 Improper Input Validation vulnerability in Wordpress
WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.
network
low complexity
wordpress
CWE-20
nessus
5.0
2019-10-17 CVE-2019-17672 Cross-Site Scripting vulnerability in Wordpress
WordPress before 5.2.4 is vulnerable to a stored XSS attack to inject JavaScript into STYLE elements.
network
wordpress
CWE-79
nessus
4.3
2019-10-17 CVE-2019-17671 Information Exposure vulnerability in Wordpress
In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is mishandled.
network
low complexity
wordpress
CWE-200
nessus
exploit available
5.0