Latest Wordpress Wordpress 4 2 8 Security Vulnerabilities

DATE CVE VULNERABILITY TITLE RISK
2019-02-20 CVE-2019-8943 Path Traversal vulnerability in Wordpress
WordPress through 5.0.3 allows Path Traversal in wp_crop_image().
network
low complexity
wordpress
CWE-22
nessus
exploit available
metasploit
4.0
2019-02-20 CVE-2019-8942 Code Injection vulnerability in Wordpress
WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring.
network
low complexity
wordpress
debian
CWE-94
nessus
exploit available
metasploit
6.5
2018-12-14 CVE-2018-20153 Cross-Site Scripting vulnerability in Wordpress
In WordPress before 4.9.9 and 5.x before 5.0.1, contributors could modify new comments made by users with greater privileges, possibly causing XSS.
network
wordpress
debian
CWE-79
nessus
3.5
2018-12-14 CVE-2018-20152 Improper Input Validation vulnerability in Wordpress
In WordPress before 4.9.9 and 5.x before 5.0.1, authors could bypass intended restrictions on post types via crafted input.
network
low complexity
wordpress
debian
CWE-20
nessus
4.0
2018-12-14 CVE-2018-20151 Information Exposure vulnerability in Wordpress
In WordPress before 4.9.9 and 5.x before 5.0.1, the user-activation page could be read by a search engine's web crawler if an unusual configuration were chosen.
network
low complexity
wordpress
debian
CWE-200
nessus
5.0
2018-12-14 CVE-2018-20150 Cross-Site Scripting vulnerability in Wordpress
In WordPress before 4.9.9 and 5.x before 5.0.1, crafted URLs could trigger XSS for certain use cases involving plugins.
network
wordpress
debian
CWE-79
nessus
4.3
2018-12-14 CVE-2018-20149 Cross-Site Scripting vulnerability in Wordpress
In WordPress before 4.9.9 and 5.x before 5.0.1, when the Apache HTTP Server is used, authors could upload crafted files that bypass intended MIME type restrictions, leading to XSS, as demonstrated by a .jpg file without JPEG data.
network
wordpress
debian
CWE-79
nessus
3.5
2018-12-14 CVE-2018-20148 Deserialization of Untrusted Data vulnerability in Wordpress
In WordPress before 4.9.9 and 5.x before 5.0.1, contributors could conduct PHP object injection attacks via crafted metadata in a wp.getMediaItem XMLRPC call.
network
low complexity
wordpress
debian
CWE-502
nessus
7.5
2018-12-14 CVE-2018-20147 Incorrect Authorization vulnerability in multiple products
In WordPress before 4.9.9 and 5.x before 5.0.1, authors could modify metadata to bypass intended restrictions on deleting files.
network
low complexity
wordpress
debian
CWE-863
nessus
5.5
2018-09-06 CVE-2018-1000773 Improper Input Validation vulnerability in Wordpress
WordPress version 4.9.8 and earlier contains a CWE-20 Input Validation vulnerability in thumbnail processing that can result in remote code execution due to an incomplete fix for CVE-2017-1000600.
network
low complexity
wordpress
CWE-20
nessus
6.5