Vulnerabilities > Webmin

DATE CVE VULNERABILITY TITLE RISK
2019-08-16 CVE-2019-15107 OS Command Injection vulnerability in Webmin
An issue was discovered in Webmin <=1.920.
network
low complexity
webmin CWE-78
critical
10.0
2019-06-15 CVE-2019-12840 OS Command Injection vulnerability in Webmin
In Webmin through 1.910, any user authorized to the "Package Updates" module can execute arbitrary commands with root privileges via the data parameter to update.cgi.
network
low complexity
webmin CWE-78
critical
9.0
2019-03-21 CVE-2018-19191 Cross-site Scripting vulnerability in Webmin 1.890
Webmin 1.890 has XSS via /config.cgi?webmin, the /shell/index.cgi history parameter, /shell/index.cgi?stripped=1, or the /webminlog/search.cgi uall or mall parameter.
network
webmin CWE-79
3.5
2019-03-07 CVE-2019-9624 Improper Privilege Management vulnerability in Webmin 1.900
Webmin 1.900 allows remote attackers to execute arbitrary code by leveraging the "Java file manager" and "Upload and Download" privileges to upload a crafted .cgi file via the /updown/upload.cgi URI.
network
webmin CWE-269
6.8
2018-03-14 CVE-2018-8712 Path Traversal vulnerability in Webmin 1.840/1.880
An issue was discovered in Webmin 1.840 and 1.880 when the default Yes setting of "Can view any file as a log file" is enabled.
network
low complexity
webmin CWE-22
5.0
2017-12-30 CVE-2017-17089 Cross-site Scripting vulnerability in Webmin
custom/run.cgi in Webmin before 1.870 allows remote authenticated administrators to conduct XSS attacks via the description field in the custom command functionality.
network
webmin CWE-79
3.5
2017-10-19 CVE-2017-15646 Cross-site Scripting vulnerability in Webmin
Webmin before 1.860 has XSS with resultant remote code execution.
network
webmin CWE-79
4.3
2017-10-19 CVE-2017-15645 Cross-Site Request Forgery (CSRF) vulnerability in Webmin
CSRF exists in Webmin 1.850.
network
webmin CWE-352
6.8
2017-10-19 CVE-2017-15644 Server-Side Request Forgery (SSRF) vulnerability in Webmin
SSRF exists in Webmin 1.850 via the PATH_INFO to tunnel/link.cgi, as demonstrated by a GET request for tunnel/link.cgi/http://INTRANET-IP:8000.
network
low complexity
webmin CWE-918
5.0
2017-07-04 CVE-2017-9313 Cross-site Scripting vulnerability in Webmin
Multiple Cross-site scripting (XSS) vulnerabilities in Webmin before 1.850 allow remote attackers to inject arbitrary web script or HTML via the sec parameter to view_man.cgi, the referers parameter to change_referers.cgi, or the name parameter to save_user.cgi.
network
webmin CWE-79
4.3