Vulnerabilities > Vanillaforums

DATE CVE VULNERABILITY TITLE RISK
2013-05-10 CVE-2013-3527 SQL Injection vulnerability in Vanillaforums Vanilla
Multiple SQL injection vulnerabilities in Vanilla Forums before 2.0.18.8 allow remote attackers to execute arbitrary SQL commands via the parameter name in the Form/Email array to (1) entry/signin or (2) entry/passwordrequest.
network
low complexity
vanillaforums CWE-89
7.5
2012-11-15 CVE-2012-4954 Permissions, Privileges, and Access Controls vulnerability in Vanillaforums Vanilla and Vanilla Forums
The edit-profile page in Vanilla Forums before 2.1a32 allows remote authenticated users to modify arbitrary profile settings by replacing the UserID value during a man-in-the-middle attack, related to a "parameter manipulation" issue.
3.5
2011-09-24 CVE-2011-3812 Information Exposure vulnerability in Vanillaforums Vanilla 2.0.16
Vanilla 2.0.16 allows remote attackers to obtain sensitive information via a direct request to a .php file, which reveals the installation path in an error message, as demonstrated by plugins/Minify/min/utils.php and certain other files.
network
low complexity
vanillaforums CWE-200
5.0
2011-02-08 CVE-2011-0910 Unspecified vulnerability in Vanillaforums Vanilla
The cookie implementation in Vanilla Forums before 2.0.17.6 makes it easier for remote attackers to spoof signed requests, and consequently obtain access to arbitrary user accounts, via HMAC timing attacks.
network
low complexity
vanillaforums
6.4
2011-02-08 CVE-2011-0909 Cross-Site Scripting vulnerability in Vanillaforums Vanilla
Cross-site scripting (XSS) vulnerability in Vanilla Forums before 2.0.17.6 allows remote attackers to inject arbitrary web script or HTML via the p parameter to an unspecified component, a different vulnerability than CVE-2011-0526.
4.3
2011-02-08 CVE-2011-0908 Improper Input Validation vulnerability in Vanillaforums Vanilla
Open redirect vulnerability in Vanilla Forums before 2.0.17.6 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via a URL in the Target parameter to an unspecified component, a different vulnerability than CVE-2011-0526.
5.8
2011-02-08 CVE-2011-0526 Cross-Site Scripting vulnerability in Vanillaforums Vanilla
Cross-site scripting (XSS) vulnerability in index.php in Vanilla Forums before 2.0.17 allows remote attackers to inject arbitrary web script or HTML via the Target parameter in a /entry/signin action.
4.3