Vulnerabilities > Shibboleth

DATE CVE VULNERABILITY TITLE RISK
2022-02-04 CVE-2022-24129 Server-Side Request Forgery (SSRF) vulnerability in Shibboleth Oidc OP
The OIDC OP plugin before 3.0.4 for Shibboleth Identity Provider allows server-side request forgery (SSRF) due to insufficient restriction of the request_uri parameter.
network
low complexity
shibboleth CWE-918
6.4
2021-04-27 CVE-2021-31826 NULL Pointer Dereference vulnerability in Shibboleth Service Provider
Shibboleth Service Provider 3.x before 3.2.2 is prone to a NULL pointer dereference flaw involving the session recovery feature.
network
low complexity
shibboleth CWE-476
5.0
2021-03-22 CVE-2021-28963 Injection vulnerability in multiple products
Shibboleth Service Provider before 3.2.1 allows content injection because template generation uses attacker-controlled parameters.
network
low complexity
shibboleth debian CWE-74
5.0
2020-10-28 CVE-2020-27978 Allocation of Resources Without Limits or Throttling vulnerability in Shibboleth Identity Provider
Shibboleth Identify Provider 3.x before 3.4.6 has a denial of service flaw.
network
low complexity
shibboleth CWE-770
5.0
2019-11-21 CVE-2019-19191 Link Following vulnerability in Shibboleth Service Provider
Shibboleth Service Provider (SP) 3.x before 3.1.0 shipped a spec file that calls chown on files in a directory controlled by the service user (the shibd account) after installation.
local
low complexity
shibboleth CWE-59
7.2
2019-11-07 CVE-2010-2450 Use of Password Hash With Insufficient Computational Effort vulnerability in multiple products
The keygen.sh script in Shibboleth SP 2.0 (located in /usr/local/etc/shibboleth by default) uses OpenSSL to create a DES private key which is placed in sp-key.pm.
network
low complexity
shibboleth debian CWE-916
5.0
2019-04-04 CVE-2014-3603 Improper Validation of Certificate with Host Mismatch vulnerability in Shibboleth Identity Provider and Opensaml Java
The (1) HttpResource and (2) FileBackedHttpResource implementations in Shibboleth Identity Provider (IdP) before 2.4.1 and OpenSAML Java 2.6.2 do not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.
4.3
2018-02-27 CVE-2018-0489 Improper Verification of Cryptographic Signature vulnerability in multiple products
Shibboleth XMLTooling-C before 1.6.4, as used in Shibboleth Service Provider before 2.6.1.4 on Windows and other products, mishandles digital signatures of user data, which allows remote attackers to obtain sensitive information or conduct impersonation attacks via crafted XML data.
network
low complexity
shibboleth debian arubanetworks CWE-347
6.4
2018-01-13 CVE-2018-0486 Improper Verification of Cryptographic Signature vulnerability in multiple products
Shibboleth XMLTooling-C before 1.6.3, as used in Shibboleth Service Provider before 2.6.0 on Windows and other products, mishandles digital signatures of user attribute data, which allows remote attackers to obtain sensitive information or conduct impersonation attacks via a crafted DTD.
network
low complexity
shibboleth debian CWE-347
6.4
2017-11-16 CVE-2017-16853 Improper Verification of Cryptographic Signature vulnerability in multiple products
The DynamicMetadataProvider class in saml/saml2/metadata/impl/DynamicMetadataProvider.cpp in OpenSAML-C in OpenSAML before 2.6.1 fails to properly configure itself with the MetadataFilter plugins and does not perform critical security checks such as signature verification, enforcement of validity periods, and other checks specific to deployments, aka CPPOST-105.
6.8