Vulnerabilities > Phpgedview

DATE CVE VULNERABILITY TITLE RISK
2004-02-17 CVE-2004-0067 Cross-Site Scripting vulnerability in PHPgedview
Multiple cross-site scripting (XSS) vulnerabilities in phpGedView before 2.65 allow remote attackers to inject arbitrary HTML or web script via (1) descendancy.php, (2) index.php, (3) individual.php, (4) login.php, (5) relationship.php, (6) source.php, (7) imageview.php, (8) calendar.php, (9) gedrecord.php, (10) login.php, and (11) gdbi_interface.php.
network
phpgedview CWE-79
4.3
2004-02-17 CVE-2004-0066 Remote Security vulnerability in PhpGedView
phpGedView before 2.65 allows remote attackers to obtain the absolute path of the web server via malformed parameters to (1) indilist.php, (2) famlist.php, (3) placelist.php, (4) imageview.php, (5) timeline.php, (6) clippings.php, (7) login.php, and (8) gdbi.php.
network
low complexity
phpgedview
5.0
2004-02-17 CVE-2004-0065 SQL Injection vulnerability in PhpGedView Placelist.PHP
Multiple SQL injection vulnerabilities in phpGedView before 2.65 allow remote attackers to execute arbitrary SQL via (1) timeline.php and (2) placelist.php.
network
low complexity
phpgedview
7.5
2004-01-20 CVE-2004-0033 Unspecified vulnerability in PHPgedview 2.61
admin.php in PHPGEDVIEW 2.61 allows remote attackers to obtain sensitive information via an action parameter with a phpinfo command.
network
low complexity
phpgedview
5.0
2004-01-20 CVE-2004-0032 Cross-Site Scripting vulnerability in PHPgedview 2.61
Cross-site scripting (XSS) vulnerability in search.php in PHPGEDVIEW 2.61 allows remote attackers to inject arbitrary HTML and web script via the firstname parameter.
network
phpgedview
6.8
2004-01-20 CVE-2004-0031 Denial-Of-Service vulnerability in PHPgedview 2.61
PHPGEDVIEW 2.61 allows remote attackers to reinstall the software and change the administrator password via a direct HTTP request to editconfig.php.
network
low complexity
phpgedview
7.5
2004-01-20 CVE-2004-0030 PHP Remote File Include vulnerability in PHPgedview 2.61
PHP remote file inclusion vulnerability in (1) functions.php, (2) authentication_index.php, and (3) config_gedcom.php for PHPGEDVIEW 2.61 allows remote attackers to execute arbitrary PHP code by modifying the PGV_BASE_DIRECTORY parameter to reference a URL on a remote web server that contains the code.
network
low complexity
phpgedview
7.5