Vulnerabilities > Libmobi Project

DATE CVE VULNERABILITY TITLE RISK
2022-04-29 CVE-2022-1533 Out-of-bounds Read vulnerability in Libmobi Project Libmobi
Buffer Over-read in GitHub repository bfabiszewski/libmobi prior to 0.11.
local
low complexity
libmobi-project CWE-125
4.6
2022-04-29 CVE-2022-1534 Out-of-bounds Read vulnerability in Libmobi Project Libmobi
Buffer Over-read at parse_rawml.c:1416 in GitHub repository bfabiszewski/libmobi prior to 0.11.
local
low complexity
libmobi-project CWE-125
3.6
2021-10-19 CVE-2021-3888 Improper Restriction of Operations within the Bounds of a Memory Buffer vulnerability in Libmobi Project Libmobi
libmobi is vulnerable to Use of Out-of-range Pointer Offset
5.8
2021-10-19 CVE-2021-3889 Improper Restriction of Operations within the Bounds of a Memory Buffer vulnerability in Libmobi Project Libmobi
libmobi is vulnerable to Use of Out-of-range Pointer Offset
5.8
2021-10-15 CVE-2021-3881 Out-of-bounds Read vulnerability in Libmobi Project Libmobi
libmobi is vulnerable to Out-of-bounds Read
network
low complexity
libmobi-project CWE-125
7.5
2021-09-15 CVE-2021-3751 Out-of-bounds Write vulnerability in Libmobi Project Libmobi
libmobi is vulnerable to Out-of-bounds Write
network
low complexity
libmobi-project CWE-787
7.5
2018-06-19 CVE-2018-11726 Out-of-bounds Write vulnerability in Libmobi Project Libmobi 0.3
The mobi_decode_font_resource function in util.c in Libmobi 0.3 allows remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via a crafted mobi file.
6.8
2018-06-19 CVE-2018-11725 Out-of-bounds Read vulnerability in Libmobi Project Libmobi 0.3
The mobi_parse_index_entry function in index.c in Libmobi 0.3 allows remote attackers to cause an information disclosure (heap-based buffer over-read) via a crafted mobi file.
4.3
2018-06-19 CVE-2018-11724 Out-of-bounds Read vulnerability in Libmobi Project Libmobi 0.3
The mobi_pk1_decrypt function in encryption.c in Libmobi 0.3 allows remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via a crafted mobi file.
6.8
2018-05-30 CVE-2018-11438 Out-of-bounds Write vulnerability in Libmobi Project Libmobi 0.3
The mobi_decompress_lz77 function in compression.c in Libmobi 0.3 allows remote attackers to cause remote code execution (heap-based buffer overflow) via a crafted mobi file.
6.8