Vulnerabilities > Jfrog

DATE CVE VULNERABILITY TITLE RISK
2022-03-02 CVE-2021-45074 Incorrect Authorization vulnerability in Jfrog Artifactory
JFrog Artifactory before 7.29.3 and 6.23.38, is vulnerable to Broken Access Control, a low-privileged user is able to delete other known users OAuth token, which will force a reauthentication on an active session or in the next UI session.
network
low complexity
jfrog CWE-863
5.5
2022-03-02 CVE-2021-46270 Incorrect Default Permissions vulnerability in Jfrog Artifactory
JFrog Artifactory before 7.31.10, is vulnerable to Broken Access Control where a project admin user is able to list all available repository names due to insufficient permission validation.
network
low complexity
jfrog CWE-276
4.0
2021-12-20 CVE-2021-3860 SQL Injection vulnerability in Jfrog Artifactory
JFrog Artifactory before 7.25.4 (Enterprise+ deployments only), is vulnerable to Blind SQL Injection by a low privileged authenticated user due to incomplete validation when performing an SQL query.
network
low complexity
jfrog CWE-89
6.5
2020-10-12 CVE-2019-17444 Weak Password Requirements vulnerability in Jfrog Artifactory
Jfrog Artifactory uses default passwords (such as "password") for administrative accounts and does not require users to change them.
network
low complexity
jfrog CWE-521
7.5
2020-03-25 CVE-2020-2165 Insufficiently Protected Credentials vulnerability in Jfrog Artifactory
Jenkins Artifactory Plugin 3.6.0 and earlier transmits configured passwords in plain text as part of its global Jenkins configuration form, potentially resulting in their exposure.
network
low complexity
jfrog CWE-522
5.0
2020-03-25 CVE-2020-2164 Insufficiently Protected Credentials vulnerability in Jfrog Artifactory
Jenkins Artifactory Plugin 3.5.0 and earlier stores its Artifactory server password unencrypted in its global configuration file on the Jenkins master where it can be viewed by users with access to the master file system.
network
low complexity
jfrog CWE-522
4.0
2020-03-16 CVE-2019-19937 Improper Input Validation vulnerability in Jfrog Artifactory
In JFrog Artifactory before 6.18, it is not possible to restrict either system or repository imports by any admin user in the enterprise, which can lead to "undesirable results."
network
low complexity
jfrog CWE-20
6.5
2020-01-23 CVE-2020-7931 Unspecified vulnerability in Jfrog Artifactory
In JFrog Artifactory 5.x and 6.x, insecure FreeMarker template processing leads to remote code execution, e.g., by modifying a .ssh/authorized_keys file.
network
low complexity
jfrog
6.5
2019-05-31 CVE-2019-10324 Cross-Site Request Forgery (CSRF) vulnerability in Jfrog Artifactory
A cross-site request forgery vulnerability in Jenkins Artifactory Plugin 3.2.2 and earlier in ReleaseAction#doSubmit, GradleReleaseApiAction#doStaging, MavenReleaseApiAction#doStaging, and UnifiedPromoteBuildAction#doSubmit allowed attackers to schedule a release build, perform release staging for Gradle and Maven projects, and promote previously staged builds, respectively.
network
jfrog CWE-352
4.3
2019-05-31 CVE-2019-10323 Permission Issues vulnerability in Jfrog Artifactory
A missing permission check in Jenkins Artifactory Plugin 3.2.3 and earlier in various 'fillCredentialsIdItems' methods allowed users with Overall/Read access to enumerate credentials ID of credentials stored in Jenkins.
network
low complexity
jfrog CWE-275
4.0