Vulnerabilities > Ikiwiki

DATE CVE VULNERABILITY TITLE RISK
2019-11-21 CVE-2015-2793 Cross-site Scripting vulnerability in multiple products
Cross-site scripting (XSS) vulnerability in templates/openid-selector.tmpl in ikiwiki before 3.20150329 allows remote attackers to inject arbitrary web script or HTML via the openid_identifier parameter in a verify action to ikiwiki.cgi.
4.3
2019-10-30 CVE-2010-1673 Cross-site Scripting vulnerability in Ikiwiki
A cross-site scripting (XSS) vulnerability in ikiwiki before 3.20101112 allows remote attackers to inject arbitrary web script or HTML via a comment.
network
ikiwiki CWE-79
4.3
2019-10-29 CVE-2011-1408 Link Following vulnerability in multiple products
ikiwiki before 3.20110608 allows remote attackers to hijack root's tty and run symlink attacks.
network
low complexity
ikiwiki debian CWE-59
6.4
2019-10-29 CVE-2011-0428 Cross-site Scripting vulnerability in Ikiwiki
Cross Site Scripting (XSS) in ikiwiki before 3.20110122 could allow remote attackers to insert arbitrary JavaScript due to insufficient checking in comments.
network
ikiwiki CWE-79
4.3
2019-06-05 CVE-2019-9187 Server-Side Request Forgery (SSRF) vulnerability in Ikiwiki
ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190228 allows SSRF via the aggregate plugin.
network
low complexity
ikiwiki CWE-918
5.0
2018-04-13 CVE-2017-0356 Improper Authentication vulnerability in multiple products
A flaw, similar to to CVE-2016-9646, exists in ikiwiki before 3.20170111, in the passwordauth plugin's use of CGI::FormBuilder, allowing an attacker to bypass authentication via repeated parameters.
network
low complexity
ikiwiki debian CWE-287
7.5
2018-04-13 CVE-2016-9646 Improper Authentication vulnerability in multiple products
ikiwiki before 3.20161229 incorrectly called the CGI::FormBuilder->field method (similar to the CGI->param API that led to Bugzilla's CVE-2014-1572), which can be abused to lead to commit metadata forgery.
network
low complexity
ikiwiki debian CWE-287
5.0
2018-04-10 CVE-2016-9645 Improper Access Control vulnerability in Ikiwiki
The fix for ikiwiki for CVE-2016-10026 was incomplete resulting in editing restriction bypass for git revert when using git versions older than 2.8.0.
network
low complexity
ikiwiki CWE-284
4.0
2017-02-13 CVE-2016-10026 Improper Access Control vulnerability in Ikiwiki 3.20161219
ikiwiki 3.20161219 does not properly check if a revision changes the access permissions for a page on sites with the git and recentchanges plugins and the CGI interface enabled, which allows remote attackers to revert certain changes by leveraging permissions to change the page before the revision was made.
network
low complexity
ikiwiki CWE-284
5.0
2016-05-10 CVE-2016-4561 Cross-site Scripting vulnerability in multiple products
Cross-site scripting (XSS) vulnerability in the cgierror function in CGI.pm in ikiwiki before 3.20160506 might allow remote attackers to inject arbitrary web script or HTML via unspecified vectors involving an error message.
4.3