Vulnerabilities > Icegram

DATE CVE VULNERABILITY TITLE RISK
2022-03-07 CVE-2022-0439 SQL Injection vulnerability in Icegram Email Subscribers & Newsletters
The Email Subscribers & Newsletters WordPress plugin before 5.3.2 does not correctly escape the `order` and `orderby` parameters to the `ajax_fetch_report_list` action, making it vulnerable to blind SQL injection attacks by users with roles as low as Subscriber.
network
low complexity
icegram CWE-89
6.5
2021-12-21 CVE-2021-24941 Cross-site Scripting vulnerability in Icegram
The Popups, Welcome Bar, Optins and Lead Generation Plugin WordPress plugin before 2.0.5 does not sanitise and escape the message_id parameter of the get_message_action_row AJAX action before outputting it back in an attribute, leading to a reflected Cross-Site Scripting issue
network
icegram CWE-79
4.3
2021-10-19 CVE-2021-36832 Cross-site Scripting vulnerability in Icegram
WordPress Popups, Welcome Bar, Optins and Lead Generation Plugin – Icegram (versions <= 2.0.2) vulnerable at "Headline" (&message_data[16][headline]) input.
network
icegram CWE-79
3.5
2020-09-10 CVE-2020-5780 Missing Authentication for Critical Function vulnerability in Icegram Email Subscribers & Newsletters
Missing Authentication for Critical Function in Icegram Email Subscribers & Newsletters Plugin for WordPress prior to version 4.5.6 allows a remote, unauthenticated attacker to conduct unauthenticated email forgery/spoofing.
network
low complexity
icegram CWE-306
5.0
2020-07-17 CVE-2020-5768 SQL Injection vulnerability in Icegram Email Subscribers & Newsletters 4.4.8
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') in Icegram Email Subscribers & Newsletters Plugin for WordPress v4.4.8 allows a remote, authenticated attacker to determine the value of database fields.
network
low complexity
icegram CWE-89
4.0
2020-07-17 CVE-2020-5767 Cross-Site Request Forgery (CSRF) vulnerability in Icegram Email Subscribers & Newsletters 4.4.8
Cross-site request forgery in Icegram Email Subscribers & Newsletters Plugin for WordPress v4.4.8 allows a remote attacker to send forged emails by tricking legitimate users into clicking a crafted link.
network
icegram CWE-352
4.3
2020-01-08 CVE-2019-20361 SQL Injection vulnerability in Icegram Email Subscribers & Newsletters
There was a flaw in the WordPress plugin, Email Subscribers & Newsletters before 4.3.1, that allowed SQL statements to be passed to the database in the hash parameter (a blind SQL injection vulnerability).
network
low complexity
icegram CWE-89
7.5
2019-12-26 CVE-2019-19985 Missing Authorization vulnerability in Icegram Email Subscribers & Newsletters
The WordPress plugin, Email Subscribers & Newsletters, before 4.2.3 had a flaw that allowed unauthenticated file download with user information disclosure.
network
low complexity
icegram CWE-862
5.0
2019-12-26 CVE-2019-19984 Incorrect Authorization vulnerability in Icegram Email Subscribers & Newsletters
The WordPress plugin, Email Subscribers & Newsletters, before 4.2.3 had a flaw that allowed users with edit_post capabilities to manage plugin settings and email campaigns.
network
low complexity
icegram CWE-863
6.5
2019-12-26 CVE-2019-19982 Improper Authentication vulnerability in Icegram Email Subscribers & Newsletters
The WordPress plugin, Email Subscribers & Newsletters, before 4.2.3 had a flaw that allowed for unauthenticated option creation.
network
low complexity
icegram CWE-287
5.0