Vulnerabilities > Acquia

DATE CVE VULNERABILITY TITLE RISK
2021-08-30 CVE-2021-27913 Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) vulnerability in Acquia Mautic
The function mt_rand is used to generate session tokens, this function is cryptographically flawed due to its nature being one pseudorandomness, an attacker can take advantage of the cryptographically insecure nature of this function to enumerate session tokens for accounts that are not under his/her control This issue affects: Mautic Mautic versions prior to 3.3.4; versions prior to 4.0.0.
network
acquia CWE-338
3.5
2021-08-30 CVE-2021-27912 Cross-site Scripting vulnerability in Acquia Mautic
Mautic versions before 3.3.4/4.0.0 are vulnerable to an inline JS XSS attack when viewing Mautic assets by utilizing inline JS in the title and adding a broken image URL as a remote asset.
network
acquia CWE-79
3.5
2021-08-30 CVE-2021-27911 Cross-site Scripting vulnerability in Acquia Mautic
Mautic versions before 3.3.4/4.0.0 are vulnerable to an inline JS XSS attack through the contact's first or last name and triggered when viewing a contact's details page then clicking on the action drop down and hovering over the Campaigns button.
network
acquia CWE-79
4.3
2021-08-30 CVE-2021-27910 Cross-site Scripting vulnerability in Acquia Mautic
Insufficient sanitization / filtering allows for arbitrary JavaScript Injection in Mautic using the bounce management callback function.
network
acquia CWE-79
4.3
2021-08-30 CVE-2021-27909 Cross-site Scripting vulnerability in Acquia Mautic
For Mautic versions prior to 3.3.4/4.0.0, there is an XSS vulnerability on Mautic's password reset page where a vulnerable parameter, "bundle," in the URL could allow an attacker to execute Javascript code.
network
acquia CWE-79
4.3
2021-03-23 CVE-2021-27908 Incorrect Permission Assignment for Critical Resource vulnerability in Acquia Mautic
In all versions prior to Mautic 3.3.2, secret parameters such as database credentials could be exposed publicly by an authorized admin user through leveraging Symfony parameter syntax in any of the free text fields in Mautic’s configuration that are used in publicly facing parts of the application.
local
low complexity
acquia CWE-732
2.1
2021-02-09 CVE-2020-35125 Cross-site Scripting vulnerability in Acquia Mautic
A cross-site scripting (XSS) vulnerability in the forms component of Mautic before 3.2.4 allows remote attackers to inject executable JavaScript via mautic[return] (a different attack method than CVE-2020-35124, but also related to the Referer concept).
network
acquia CWE-79
6.8
2021-01-28 CVE-2020-35124 Cross-site Scripting vulnerability in Acquia Mautic
A cross-site scripting (XSS) vulnerability in the assets component of Mautic before 3.2.4 allows remote attackers to inject executable JavaScript through the Referer header of asset downloads.
network
acquia CWE-79
6.8
2021-01-19 CVE-2020-35128 Cross-site Scripting vulnerability in Acquia Mautic
Mautic before 3.2.4 is affected by stored XSS.
network
acquia CWE-79
6.0
2019-09-20 CVE-2018-11200 Cross-site Scripting vulnerability in Acquia Mautic 2.13.1
An issue was discovered in Mautic 2.13.1.
network
acquia CWE-79
4.3