Vulnerabilities > CVE-2022-37434 - Out-of-bounds Write vulnerability in multiple products

047910
CVSS 9.8 - CRITICAL
Attack vector
NETWORK
Attack complexity
LOW
Privileges required
NONE
Confidentiality impact
HIGH
Integrity impact
HIGH
Availability impact
HIGH
network
low complexity
zlib
fedoraproject
debian
netapp
apple
CWE-787
critical

Summary

zlib through 1.2.12 has a heap-based buffer over-read or buffer overflow in inflate in inflate.c via a large gzip header extra field. NOTE: only applications that call inflateGetHeader are affected. Some common applications bundle the affected zlib source code but may be unable to call inflateGetHeader (e.g., see the nodejs/node reference).

Vulnerable Configurations

Part Description Count
Application
Zlib
79
Application
Netapp
7
OS
Fedoraproject
3
OS
Debian
1
OS
Netapp
3
OS
Apple
371
Hardware
Netapp
4

Common Weakness Enumeration (CWE)

References