CVE-2019-5727 - Cross-Site Scripting (XSS) vulnerability in Splunk

Publication

2019-02-21

Last modification

2019-02-22

Summary

Splunk Web in Splunk Enterprise 6.5.x before 6.5.5, 6.4.x before 6.4.9, 6.3.x before 6.3.12, 6.2.x before 6.2.14, 6.1.x before 6.1.14, and 6.0.x before 6.0.15 and Splunk Light before 6.6.0 has Persistent XSS, aka SPL-138827.

Description

Splunk Enterprise and Splunk Lite is prone to an HTML-injection vulnerability. An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and launch other attacks. The following versions are affected: Versions prior to Splunk Enterprise 6.5.5, 6.4.9, 6.3.12, 6.2.14, and 6.0.15 are vulnerable. Versions prior to Splunk Light 6.6.0 are vulnerable.

Solution

Updates are available. Please see the references or vendor advisory for more information.

Exploit

Attackers can exploit this issue using browser.

Classification

CWE-79 - Cross-Site Scripting (XSS)

Risk level (CVSS AV:N/AC:M/Au:S/C:N/I:P/A:N)

Low

3.5

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products