CVE-2019-3886 - Information Leak / Disclosure vulnerability in Opensuse and Redhat products

Publication

2019-04-04

Last modification

2019-05-02

Summary

An incorrect permissions check was discovered in libvirt 4.8.0 and above. The readonly permission was allowed to invoke APIs depending on the guest agent, which could lead to potentially disclosing unintended information or denial of service by causing libvirt to block.

Description

libvirt is prone to a security-bypass vulnerability. Attackers can exploit this issue to bypass certain security restrictions to perform unauthorized actions. This may aid in further attacks. libvirt version 4.8.0 and later are vulnerable.

Solution

Updates are available. Please see the references or vendor advisory for more information.

Exploit

Currently, we are not aware of any working exploits.

Classification

CWE-200 - Information Leak / Disclosure

Risk level (CVSS AV:A/AC:L/Au:N/C:P/I:N/A:P)

Medium

4.8

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

Vendor Product Versions
Opensuse Leap  42.3
Redhat Libvirt  5.1.0 , 4.10.0 , 5.0.0 , 5.2.0 , 4.8.0 , 4.9.0