CVE-2011-3859 - Cross-Site Scripting (XSS) vulnerability in Themehybrid Trending 0.1

Publication

2011-09-28

Last modification

2012-05-18

Summary

Cross-site scripting (XSS) vulnerability in the Trending theme before 0.2 for WordPress allows remote attackers to inject arbitrary web script or HTML via the cpage parameter.

Description

The Trending theme for WordPress is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks. Versions prior to Trending theme 0.2 are vulnerable.

Solution

Updates are available. Please see the references for more details.

Exploit

Attackers can exploit this issue by enticing an unsuspecting victim to follow a malicious URI.The following example URI is available: http://www.exmaple.com/?p=8&cpage=[xss]

Classification

CWE-79 - Cross-Site Scripting (XSS)

Risk level (CVSS AV:N/AC:M/Au:N/C:N/I:P/A:N)

Medium

4.3

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

Vendor Product Versions
Themehybrid Trending  0.1