CVE-2011-3854 - Cross-Site Scripting (XSS) vulnerability in Quirm Zenlite

Publication

2011-09-28

Last modification

2011-10-21

Summary

Cross-site scripting (XSS) vulnerability in the ZenLite theme before 4.4 for WordPress allows remote attackers to inject arbitrary web script or HTML via the s parameter.

Description

The ZenLite theme for WordPress is prone to a cross-site-scripting vulnerability because it fails to properly sanitize user-supplied input.An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks. Versions prior to ZenLite theme 4.4 are vulnerable.

Solution

Updates are available. Please see the references for more details.

Exploit

Attackers can exploit this issue by enticing an unsuspecting victim to follow a malicious URI.The following example URI is available: http://www.example.com/?p=8&s=[XSS]

Classification

CWE-79 - Cross-Site Scripting (XSS)

Risk level (CVSS AV:N/AC:M/Au:N/C:N/I:P/A:N)

Medium

4.3

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

Vendor Product Versions
Quirm Zenlite  3.0 , 4.1 , 1.0 , 3.2 , 2.5 , 2.2 , 4.3 , 1.1 , 3.4 , 2.4 , 3.1 , 3.61 , 4.2 , 2.6 , 3.3 , 2.0 , 1.3 , 2.7 , 3.60 , 2.1 , 4.0 , 3.52 , 3.51 , 1.2 , 3.5