Critical

CVE-2009-0186 - Numeric Errors vulnerability in multiple products

Publication: 2009-03-05
Summary

Integer overflow in libsndfile 1.0.18, as used in Winamp and other products, allows context-dependent attackers to execute arbitrary code via crafted description chunks in a CAF audio file, leading to a heap-based buffer overflow.

Classification
CWE-189: Numeric Errors

Risk level (CVSS 9.3)

Critical

9.3

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

  • Mega-nerd Libsndfile 0.0.8
  • Mega-nerd Libsndfile 0.0.28
  • Mega-nerd Libsndfile 1.0.0
  • Mega-nerd Libsndfile 1.0.0
  • Mega-nerd Libsndfile 1.0.0
  • Mega-nerd Libsndfile 1.0.1
  • Mega-nerd Libsndfile 1.0.2
  • Mega-nerd Libsndfile 1.0.3
  • Mega-nerd Libsndfile 1.0.4
  • Mega-nerd Libsndfile 1.0.5
  • Mega-nerd Libsndfile 1.0.6
  • Mega-nerd Libsndfile 1.0.7
  • Mega-nerd Libsndfile 1.0.8
  • Mega-nerd Libsndfile 1.0.9
  • Mega-nerd Libsndfile 1.0.10
  • Mega-nerd Libsndfile 1.0.11
  • Mega-nerd Libsndfile 1.0.12
  • Mega-nerd Libsndfile 1.0.13
  • Mega-nerd Libsndfile 1.0.14
  • Mega-nerd Libsndfile 1.0.15
  • Mega-nerd Libsndfile 1.0.16
  • Mega-nerd Libsndfile 1.0.17
  • Mega-nerd Libsndfile 1.0.18
  • Nullsoft Winamp 5.55
  • Nullsoft Winamp 5.541