High

CVE-2009-0180 - Permissions, Privileges, and Access Control vulnerability in NFS-Utils

Publication: 2009-01-20
Summary

Certain Fedora build scripts for nfs-utils before 1.1.2-9.fc9 on Fedora 9, and before 1.1.4-6.fc10 on Fedora 10, omit TCP Wrapper support, which might allow remote attackers to bypass intended access restrictions, possibly a related issue to CVE-2008-1376.

Classification
CWE-264: Permissions, Privileges, and Access Control

Risk level (CVSS 7.5)

High

7.5

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

  • NFS NFS-utils 0.2
  • NFS NFS-utils 0.2.1
  • NFS NFS-utils 0.3.1
  • NFS NFS-utils 0.3.3
  • NFS NFS-utils 1.0
  • NFS NFS-utils 1.0.1
  • NFS NFS-utils 1.0.2
  • NFS NFS-utils 1.0.3
  • NFS NFS-utils 1.0.4
  • NFS NFS-utils 1.0.6
  • NFS NFS-utils 1.0.7
  • NFS NFS-utils 1.0.7
  • NFS NFS-utils 1.0.7
  • NFS NFS-utils 1.0.8
  • NFS NFS-utils 1.0.8
  • NFS NFS-utils 1.0.8
  • NFS NFS-utils 1.0.8
  • NFS NFS-utils 1.0.8
  • NFS NFS-utils 1.0.9
  • NFS NFS-utils 1.0.10
  • NFS NFS-utils 1.0.11
  • NFS NFS-utils 1.0.12
  • NFS NFS-utils 1.1.0
  • NFS NFS-utils 1.1.0
  • NFS NFS-utils 1.1.1
  • NFS NFS-utils 1.1.2
  • NFS NFS-utils 1.1.3
  • NFS NFS-utils 1.1.4