Moderate

CVE-2009-0177 - Resource Management Errors vulnerability in Vmware products

Publication: 2009-01-20
Summary

vmwarebase.dll, as used in the vmware-authd service (aka vmware-authd.exe), in VMware Workstation 6.5.1 build 126130, 6.5.1 and earlier; VMware Player 2.5.1 build 126130, 2.5.1 and earlier; VMware ACE 2.5.1 and earlier; VMware Server 2.0.x before 2.0.1 build 156745; and VMware Fusion before 2.0.2 build 147997 allows remote attackers to cause a denial of service (daemon crash) via a long (1) USER or (2) PASS command.

Classification
CWE-399: Resource Management Errors

Risk level (CVSS 5)

Moderate

5.0

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

  • Vmware Vmware Player 1.0.0
  • Vmware Vmware Player 1.0.1
  • Vmware Vmware Player 1.0.2
  • Vmware Vmware Player 1.0.3
  • Vmware Vmware Player 1.0.4
  • Vmware Vmware Player 1.0.6
  • Vmware Vmware Player 1.0.7
  • Vmware Vmware Player 1.0.8
  • Vmware Vmware Player 1.0.9
  • Vmware Vmware Player 1.05
  • Vmware Server 2.0.0
  • Vmware Vmware Player 2.0
  • Vmware Fusion 2.0.1
  • Vmware Vmware Player 2.0.1
  • Vmware Vmware Player 2.0.2
  • Vmware Vmware Player 2.0.3
  • Vmware Vmware Player 2.0.4
  • Vmware Vmware Player 2.0.5
  • Vmware Vmware Player 2.5
  • Vmware ACE 2.5.0
  • Vmware ACE 2.5.1
  • Vmware Vmware Player 2.5.1
  • Vmware Vmware Workstation 4.5.3
  • Vmware Vmware Workstation 5.0
  • Vmware Vmware Workstation 5.5.0
  • Vmware Vmware Workstation 5.5.1
  • Vmware Vmware Workstation 5.5.2
  • Vmware Vmware Workstation 5.5.3
  • Vmware Vmware Workstation 5.5.4
  • Vmware Vmware Workstation 5.5.5
  • Vmware Vmware Workstation 5.5.6
  • Vmware Vmware Workstation 5.5.7
  • Vmware Vmware Workstation 5.5.8
  • Vmware Vmware Workstation 6.0
  • Vmware Vmware Workstation 6.0.1
  • Vmware Vmware Workstation 6.0.2
  • Vmware Vmware Workstation 6.0.3
  • Vmware Vmware Workstation 6.0.4
  • Vmware Vmware Workstation 6.0.5
  • Vmware Vmware Workstation 6.5
  • Vmware Vmware Workstation 6.51