Moderate

CVE-2009-0162 - Cross-Site Scripting (XSS) vulnerability in Apple Safari

Publication: 2009-05-13
Summary

Cross-site scripting (XSS) vulnerability in Safari before 3.2.3, and 4 Public Beta, on Apple Mac OS X 10.5 before 10.5.7 and Windows allows remote attackers to inject arbitrary web script or HTML via a crafted feed: URL.

Classification
CWE-79: Cross-Site Scripting (XSS)

Risk level (CVSS 4.3)

Moderate

4.3

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

  • Apple Safari 0.8
  • Apple Safari 0.9
  • Apple Safari 1.0
  • Apple Safari 1.0
  • Apple Safari 1.0
  • Apple Safari 1.0.0
  • Apple Safari 1.0.1
  • Apple Safari 1.0.2
  • Apple Safari 1.0.3
  • Apple Safari 1.0.3
  • Apple Safari 1.0.3
  • Apple Safari 1.1
  • Apple Safari 1.1.0
  • Apple Safari 1.1.1
  • Apple Safari 1.2.0
  • Apple Safari 1.2
  • Apple Safari 1.2.1
  • Apple Safari 1.2.2
  • Apple Safari 1.2.3
  • Apple Safari 1.2.4
  • Apple Safari 1.2.5
  • Apple Safari 1.3
  • Apple Safari 1.3.0
  • Apple Safari 1.3.1
  • Apple Safari 1.0.0b1
  • Apple Safari 1.0.0b2
  • Apple Safari 1.3.2
  • Apple Safari 1.3.2
  • Apple Safari 1.3.2
  • Apple Safari 2
  • Apple Safari 2.0
  • Apple Safari 2.0.0
  • Apple Safari 2.0.1
  • Apple Safari 2.0.2
  • Apple Safari 2.0.3
  • Apple Safari 2.0.3
  • Apple Safari 2.0.3
  • Apple Safari 2.0.3
  • Apple Safari 2.0.4
  • Apple Safari 3
  • Apple Safari 3.0
  • Apple Safari 3.0.0
  • Apple Safari 3.0.1
  • Apple Safari 3.0.2
  • Apple Safari 3.0.3
  • Apple Safari 3.0.4
  • Apple Safari 3.1
  • Apple Safari 3.1.0
  • Apple Safari 3.1.1
  • Apple Safari 3.1.2
  • Apple Safari 3.2
  • Apple Safari 3.2.0
  • Apple Safari 3.2.1
  • Apple Safari 3.2.2
  • Apple Safari 4.0