Moderate

CVE-2009-0161 - Input Validation vulnerability in Apple MAC OS X Server

Publication: 2009-05-13
Summary

The OpenSSL::OCSP module for Ruby in Apple Mac OS X 10.5 before 10.5.7 misinterprets an unspecified invalid response as a successful OCSP certificate validation, which might allow remote attackers to spoof certificate authentication via a revoked certificate.

Classification
CWE-20: Input Validation

Risk level (CVSS 6.4)

Moderate

6.4

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

  • Apple MAC OS X Server 10.4.11
  • Apple MAC OS X 10.5.0
  • Apple MAC OS X Server 10.5.0
  • Apple MAC OS X 10.5.1
  • Apple MAC OS X Server 10.5.1
  • Apple MAC OS X 10.5.2
  • Apple MAC OS X Server 10.5.2
  • Apple MAC OS X Server 10.5.3
  • Apple MAC OS X 10.5.3
  • Apple MAC OS X 10.5.4
  • Apple MAC OS X Server 10.5.4
  • Apple MAC OS X 10.5.5
  • Apple MAC OS X 10.5.6
  • Apple MAC OS X Server 10.5.6