Moderate

CVE-2009-0160 - Code Injection vulnerability in Apple MAC OS X Server

Publication: 2009-05-13
Summary

QuickDraw Manager in Apple Mac OS X 10.4.11 and 10.5 before 10.5.7 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted PICT image that triggers memory corruption.

Classification
CWE-94: Code Injection

Risk level (CVSS 6.8)

Moderate

6.8

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

  • Apple MAC OS X Server 10.4.11
  • Apple MAC OS X 10.4.11
  • Apple MAC OS X Server 10.5.0
  • Apple MAC OS X 10.5.0
  • Apple MAC OS X Server 10.5.1
  • Apple MAC OS X 10.5.1
  • Apple MAC OS X 10.5.2
  • Apple MAC OS X Server 10.5.2
  • Apple MAC OS X 10.5.3
  • Apple MAC OS X Server 10.5.3
  • Apple MAC OS X 10.5.4
  • Apple MAC OS X Server 10.5.4
  • Apple MAC OS X 10.5.5
  • Apple MAC OS X Server 10.5.5
  • Apple MAC OS X 10.5.6
  • Apple MAC OS X Server 10.5.6