CVE-2008-5805 - SQL Injection vulnerability in Deltascripts PHP Classifieds

Publication

2008-12-31

Last modification

2017-09-29

Summary

SQL injection vulnerability in detail.php in DeltaScripts PHP Classifieds 7.5 and earlier allows remote attackers to execute arbitrary SQL commands via the siteid parameter, a different vector than CVE-2006-5828.

Description

DeltaScripts PHP Classifieds is prone to multiple SQL-injection vulnerabilities because it fails to sufficiently sanitize user-supplied data before using it in an SQL query.Exploiting these issues could allow an attacker to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.PHP Classifieds 7.3 is vulnerable; other versions may also be affected.

Solution

Currently we are not aware of any vendor-supplied patches. If you feel we are in error or if you are aware of more recent information, please mail us at: info@vumetric.com.

Exploit

Attackers can use a browser to exploit these issues.The following example parameters are available:admin: admin ' or ' 1=1passwd: ZoRLu

Classification

CWE-89 - SQL Injection

Risk level (CVSS AV:N/AC:L/Au:N/C:P/I:P/A:P)

High

7.5

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

Vendor Product Versions
Deltascripts PHP Classifieds  7.0 , 6.18 , 6.0.5 , 7.3 , 7.5 , 7.1 , 6.19 , 6.20 , 6.04 , 7.2