Vulnerabilities > CVE-2008-4817 - Improper Input Validation vulnerability in Adobe Acrobat and Acrobat Reader

047910
CVSS 9.3 - CRITICAL
Attack vector
NETWORK
Attack complexity
MEDIUM
Privileges required
NONE
Confidentiality impact
COMPLETE
Integrity impact
COMPLETE
Availability impact
COMPLETE
network
adobe
CWE-20
critical
nessus

Summary

The Download Manager in Adobe Acrobat Professional and Reader 8.1.2 and earlier allows remote attackers to execute arbitrary code via a crafted PDF document that calls an AcroJS function with a long string argument, triggering heap corruption.

Common Weakness Enumeration (CWE)

Common Attack Pattern Enumeration and Classification (CAPEC)

  • Buffer Overflow via Environment Variables
    This attack pattern involves causing a buffer overflow through manipulation of environment variables. Once the attacker finds that they can modify an environment variable, they may try to overflow associated buffers. This attack leverages implicit trust often placed in environment variables.
  • Server Side Include (SSI) Injection
    An attacker can use Server Side Include (SSI) Injection to send code to a web application that then gets executed by the web server. Doing so enables the attacker to achieve similar results to Cross Site Scripting, viz., arbitrary code execution and information disclosure, albeit on a more limited scale, since the SSI directives are nowhere near as powerful as a full-fledged scripting language. Nonetheless, the attacker can conveniently gain access to sensitive files, such as password files, and execute shell commands.
  • Cross Zone Scripting
    An attacker is able to cause a victim to load content into their web-browser that bypasses security zone controls and gain access to increased privileges to execute scripting code or other web objects such as unsigned ActiveX controls or applets. This is a privilege elevation attack targeted at zone-based web-browser security. In a zone-based model, pages belong to one of a set of zones corresponding to the level of privilege assigned to that page. Pages in an untrusted zone would have a lesser level of access to the system and/or be restricted in the types of executable content it was allowed to invoke. In a cross-zone scripting attack, a page that should be assigned to a less privileged zone is granted the privileges of a more trusted zone. This can be accomplished by exploiting bugs in the browser, exploiting incorrect configuration in the zone controls, through a cross-site scripting attack that causes the attackers' content to be treated as coming from a more trusted page, or by leveraging some piece of system functionality that is accessible from both the trusted and less trusted zone. This attack differs from "Restful Privilege Escalation" in that the latter correlates to the inadequate securing of RESTful access methods (such as HTTP DELETE) on the server, while cross-zone scripting attacks the concept of security zones as implemented by a browser.
  • Cross Site Scripting through Log Files
    An attacker may leverage a system weakness where logs are susceptible to log injection to insert scripts into the system's logs. If these logs are later viewed by an administrator through a thin administrative interface and the log data is not properly HTML encoded before being written to the page, the attackers' scripts stored in the log will be executed in the administrative interface with potentially serious consequences. This attack pattern is really a combination of two other attack patterns: log injection and stored cross site scripting.
  • Command Line Execution through SQL Injection
    An attacker uses standard SQL injection methods to inject data into the command line for execution. This could be done directly through misuse of directives such as MSSQL_xp_cmdshell or indirectly through injection of data into the database that would be interpreted as shell commands. Sometime later, an unscrupulous backend application (or could be part of the functionality of the same application) fetches the injected data stored in the database and uses this data as command line arguments without performing proper validation. The malicious data escapes that data plane by spawning new commands to be executed on the host.

Nessus

  • NASL familyRed Hat Local Security Checks
    NASL idREDHAT-RHSA-2008-0974.NASL
    descriptionUpdated acroread packages that fix various security issues are now available for Red Hat Enterprise Linux 3 Extras, Red Hat Enterprise Linux 4 Extras, and Red Hat Enterprise Linux 5 Supplementary. This update has been rated as having critical security impact by the Red Hat Security Response Team. Adobe Reader allows users to view and print documents in Portable Document Format (PDF). Several input validation flaws were discovered in Adobe Reader. A malicious PDF file could cause Adobe Reader to crash or, potentially, execute arbitrary code as the user running Adobe Reader. (CVE-2008-2549, CVE-2008-2992, CVE-2008-4812, CVE-2008-4813, CVE-2008-4814, CVE-2008-4817) The Adobe Reader binary had an insecure relative RPATH (runtime library search path) set in the ELF (Executable and Linking Format) header. A local attacker able to convince another user to run Adobe Reader in an attacker-controlled directory could run arbitrary code with the privileges of the victim. (CVE-2008-4815) All acroread users are advised to upgrade to these updated packages, that contain Adobe Reader version 8.1.3, and are not vulnerable to these issues.
    last seen2020-06-01
    modified2020-06-02
    plugin id40730
    published2009-08-24
    reporterThis script is Copyright (C) 2009-2019 and is owned by Tenable, Inc. or an Affiliate thereof.
    sourcehttps://www.tenable.com/plugins/nessus/40730
    titleRHEL 3 / 4 / 5 : acroread (RHSA-2008:0974)
  • NASL familySuSE Local Security Checks
    NASL idSUSE_ACROREAD-5746.NASL
    descriptionThe acroread package was update to fix several security vulnerabilities in the JavaScript engine. (CVE-2008-2992 / CVE-2008-2549 / CVE-2008-4812 / CVE-2008-4813 / CVE-2008-4817 / CVE-2008-4816 / CVE-2008-4814 / CVE-2008-4815)
    last seen2020-06-01
    modified2020-06-02
    plugin id34942
    published2008-11-24
    reporterThis script is Copyright (C) 2008-2019 Tenable Network Security, Inc.
    sourcehttps://www.tenable.com/plugins/nessus/34942
    titleSuSE 10 Security Update : Acrobat Reader (ZYPP Patch Number 5746)
  • NASL familySuSE Local Security Checks
    NASL idSUSE_11_0_ACROREAD-081107.NASL
    descriptionThe acroread package was update to fix several security vulnerabilities in the JavaScript engine. (CVE-2008-2992, CVE-2008-2549, CVE-2008-4812, CVE-2008-4813, CVE-2008-4817, CVE-2008-4816, CVE-2008-4814, CVE-2008-4815)
    last seen2020-06-01
    modified2020-06-02
    plugin id39905
    published2009-07-21
    reporterThis script is Copyright (C) 2009-2019 Tenable Network Security, Inc.
    sourcehttps://www.tenable.com/plugins/nessus/39905
    titleopenSUSE Security Update : acroread (acroread-295)
  • NASL familyWindows
    NASL idADOBE_ACROBAT_813.NASL
    descriptionThe version of Adobe Acrobat installed on the remote host is earlier than 9.0 / 8.1.3. Such versions are reportedly affected by multiple vulnerabilities : - There is a published denial of service issue. (CVE-2008-2549) - A stack-based buffer overflow when parsing format strings containing a floating point specifier in the
    last seen2020-06-01
    modified2020-06-02
    plugin id40802
    published2009-08-28
    reporterThis script is Copyright (C) 2009-2018 Tenable Network Security, Inc.
    sourcehttps://www.tenable.com/plugins/nessus/40802
    titleAdobe Acrobat < 8.1.3 Multiple Vulnerabilities
  • NASL familyWindows
    NASL idADOBE_READER_813.NASL
    descriptionThe version of Adobe Reader installed on the remote host is earlier than 8.1.3. Such versions are reportedly affected by multiple vulnerabilities : - There is a publicly-published denial of service issue (CVE-2008-2549). - A stack-based buffer overflow when parsing format strings containing a floating point specifier in the
    last seen2020-06-01
    modified2020-06-02
    plugin id34695
    published2008-11-04
    reporterThis script is Copyright (C) 2008-2018 Tenable Network Security, Inc.
    sourcehttps://www.tenable.com/plugins/nessus/34695
    titleAdobe Reader < 8.1.3 / 9.0 Multiple Vulnerabilities
  • NASL familySuSE Local Security Checks
    NASL idSUSE_ACROREAD-5749.NASL
    descriptionThe acroread package was update to fix several security vulnerabilities in the JavaScript engine. (CVE-2008-2992, CVE-2008-2549, CVE-2008-4812, CVE-2008-4813, CVE-2008-4817, CVE-2008-4816, CVE-2008-4814, CVE-2008-4815)
    last seen2020-06-01
    modified2020-06-02
    plugin id34943
    published2008-11-24
    reporterThis script is Copyright (C) 2008-2019 Tenable Network Security, Inc.
    sourcehttps://www.tenable.com/plugins/nessus/34943
    titleopenSUSE 10 Security Update : acroread (acroread-5749)
  • NASL familyGentoo Local Security Checks
    NASL idGENTOO_GLSA-200901-09.NASL
    descriptionThe remote host is affected by the vulnerability described in GLSA-200901-09 (Adobe Reader: User-assisted execution of arbitrary code) An unspecified vulnerability can be triggered by a malformed PDF document, as demonstrated by 2008-HI2.pdf (CVE-2008-2549). Peter Vreugdenhil, Dyon Balding, Will Dormann, Damian Frizza, and Greg MacManus reported a stack-based buffer overflow in the util.printf JavaScript function that incorrectly handles the format string argument (CVE-2008-2992). Greg MacManus of iDefense Labs reported an array index error that can be leveraged for an out-of-bounds write, related to parsing of Type 1 fonts (CVE-2008-4812). Javier Vicente Vallejo and Peter Vregdenhil, via Zero Day Initiative, reported multiple unspecified memory corruption vulnerabilities (CVE-2008-4813). Thomas Garnier of SkyRecon Systems reported an unspecified vulnerability in a JavaScript method, related to an
    last seen2020-06-01
    modified2020-06-02
    plugin id35367
    published2009-01-14
    reporterThis script is Copyright (C) 2009-2019 Tenable Network Security, Inc.
    sourcehttps://www.tenable.com/plugins/nessus/35367
    titleGLSA-200901-09 : Adobe Reader: User-assisted execution of arbitrary code

Redhat

advisories
rhsa
idRHSA-2008:0974
rpms
  • acroread-0:8.1.3-1
  • acroread-0:8.1.3-1.el4
  • acroread-0:8.1.3-1.el5
  • acroread-plugin-0:8.1.3-1
  • acroread-plugin-0:8.1.3-1.el4
  • acroread-plugin-0:8.1.3-1.el5

Seebug

bulletinFamilyexploit
descriptionCVE ID:CVE-2008-4817 NOS Microsystems getPlus是一款下载管理器控件。 NOS Microsystems getPlus控件处理安装文件时存在缓冲区溢出,远程攻击者可以利用漏洞以应用程序权限执行任意指令。 存在问题的控件为 getPlus gp.ocx 1.2.2.50,目前证实用于Adobe Reader 8.1的WEB安装使用此控件,要判断此版本控件是否安装,注册表编辑器可用于尝试浏览此注册表键值: HKEY_CLASSES_ROOT\CLSID\{CF40ACC5-E1BB-4aff-AC72-04C2F616BCA7} 如果这个KEY存在就表示此控件安装。 NOS Microsystems getPlus 1.x Adobe已经提供了更新已修补此漏洞: <a href=http://www.adobe.com/support/security/bulletins/apsb08-19.html target=_blank>http://www.adobe.com/support/security/bulletins/apsb08-19.html</a> 或为如下CLSID设置Kill位来进行临时解决方案: CF40ACC5-E1BB-4aff-AC72-04C2F616BCA7
idSSV:4417
last seen2017-11-19
modified2008-11-07
published2008-11-07
reporterRoot
titleNOS Microsystems getPlus ActiveX控件缓冲区溢出漏洞