Vulnerabilities > CVE-2008-2514 - Buffer Errors vulnerability in IBM AIX 5.2/5.3/6.1

047910
CVSS 4.6 - MEDIUM
Attack vector
LOCAL
Attack complexity
LOW
Privileges required
NONE
Confidentiality impact
PARTIAL
Integrity impact
PARTIAL
Availability impact
PARTIAL
local
low complexity
ibm
CWE-119
nessus

Summary

Buffer overflow in errpt in IBM AIX 5.2, 5.3, and 6.1 allows local users to gain privileges via unknown attack vectors.

Vulnerable Configurations

Part Description Count
OS
Ibm
3

Common Attack Pattern Enumeration and Classification (CAPEC)

  • Buffer Overflow via Environment Variables
    This attack pattern involves causing a buffer overflow through manipulation of environment variables. Once the attacker finds that they can modify an environment variable, they may try to overflow associated buffers. This attack leverages implicit trust often placed in environment variables.
  • Overflow Buffers
    Buffer Overflow attacks target improper or missing bounds checking on buffer operations, typically triggered by input injected by an attacker. As a consequence, an attacker is able to write past the boundaries of allocated buffer regions in memory, causing a program crash or potentially redirection of execution as per the attackers' choice.
  • Client-side Injection-induced Buffer Overflow
    This type of attack exploits a buffer overflow vulnerability in targeted client software through injection of malicious content from a custom-built hostile service.
  • Filter Failure through Buffer Overflow
    In this attack, the idea is to cause an active filter to fail by causing an oversized transaction. An attacker may try to feed overly long input strings to the program in an attempt to overwhelm the filter (by causing a buffer overflow) and hoping that the filter does not fail securely (i.e. the user input is let into the system unfiltered).
  • MIME Conversion
    An attacker exploits a weakness in the MIME conversion routine to cause a buffer overflow and gain control over the mail server machine. The MIME system is designed to allow various different information formats to be interpreted and sent via e-mail. Attack points exist when data are converted to MIME compatible format and back.

Nessus

  • NASL familyAIX Local Security Checks
    NASL idAIX_IZ22348.NASL
    descriptionThe errpt command contains a buffer which can overflow. A local attacker may exploit this overflow to execute arbitrary code with root privileges because the command is setuid root. The following files are vulnerable : /usr/bin/errpt.
    last seen2020-06-01
    modified2020-06-02
    plugin id63769
    published2013-01-24
    reporterThis script is Copyright (C) 2013-2019 Tenable Network Security, Inc.
    sourcehttps://www.tenable.com/plugins/nessus/63769
    titleAIX 6.1 TL 0 : errpt (IZ22348)
    code
    #%NASL_MIN_LEVEL 80502
    #
    # (C) Tenable Network Security, Inc.
    #
    # The text in the description was extracted from AIX Security
    # Advisory errpt_advisory.asc.
    #
    
    include("compat.inc");
    
    if (description)
    {
      script_id(63769);
      script_version("1.3");
      script_cvs_date("Date: 2019/09/16 14:12:49");
    
      script_cve_id("CVE-2008-2514");
    
      script_name(english:"AIX 6.1 TL 0 : errpt (IZ22348)");
      script_summary(english:"Check for APAR IZ22348");
    
      script_set_attribute(
        attribute:"synopsis", 
        value:"The remote AIX host is missing a security patch."
      );
      script_set_attribute(
        attribute:"description", 
        value:
    "The errpt command contains a buffer which can overflow. A local
    attacker may exploit this overflow to execute arbitrary code with root
    privileges because the command is setuid root.
    
    The following files are vulnerable :
    
    /usr/bin/errpt."
      );
      script_set_attribute(
        attribute:"see_also",
        value:"http://aix.software.ibm.com/aix/efixes/security/errpt_advisory.asc"
      );
      script_set_attribute(
        attribute:"solution", 
        value:"Install the appropriate interim fix."
      );
      script_set_cvss_base_vector("CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P");
      script_cwe_id(119);
    
      script_set_attribute(attribute:"plugin_type", value:"local");
      script_set_attribute(attribute:"cpe", value:"cpe:/o:ibm:aix:6.1");
    
      script_set_attribute(attribute:"vuln_publication_date", value:"2008/05/21");
      script_set_attribute(attribute:"patch_publication_date", value:"2008/05/21");
      script_set_attribute(attribute:"plugin_publication_date", value:"2013/01/24");
      script_end_attributes();
    
      script_category(ACT_GATHER_INFO);
      script_copyright(english:"This script is Copyright (C) 2013-2019 Tenable Network Security, Inc.");
      script_family(english:"AIX Local Security Checks");
    
      script_dependencies("ssh_get_info.nasl");
      script_require_keys("Host/AIX/lslpp", "Host/local_checks_enabled", "Host/AIX/version");
    
      exit(0);
    }
    
    
    
    include("audit.inc");
    include("global_settings.inc");
    include("aix.inc");
    include("misc_func.inc");
    
    if ( ! get_kb_item("Host/local_checks_enabled") ) audit(AUDIT_LOCAL_CHECKS_NOT_ENABLED);
    if ( ! get_kb_item("Host/AIX/version") ) audit(AUDIT_OS_NOT, "AIX");
    if ( ! get_kb_item("Host/AIX/lslpp") ) audit(AUDIT_PACKAGE_LIST_MISSING);
    
    if ( get_kb_item("Host/AIX/emgr_failure" ) ) exit(0, "This iFix check is disabled because : "+get_kb_item("Host/AIX/emgr_failure") );
    
    flag = 0;
    
    if (aix_check_ifix(release:"6.1", ml:"00", patch:"IZ22348_00", package:"aid", minfilesetver:"6.1.0.0", maxfilesetver:"6.1.0.3") < 0) flag++;
    
    if (flag)
    {
      if (report_verbosity > 0) security_warning(port:0, extra:aix_report_get());
      else security_warning(0);
      exit(0);
    }
    else audit(AUDIT_HOST_NOT, "affected");
    
  • NASL familyAIX Local Security Checks
    NASL idAIX_IZ22346.NASL
    descriptionThe errpt command contains a buffer which can overflow. A local attacker may exploit this overflow to execute arbitrary code with root privileges because the command is setuid root. The following files are vulnerable : /usr/bin/errpt.
    last seen2020-06-01
    modified2020-06-02
    plugin id63767
    published2013-01-24
    reporterThis script is Copyright (C) 2013-2019 Tenable Network Security, Inc.
    sourcehttps://www.tenable.com/plugins/nessus/63767
    titleAIX 5.3 TL 0 : errpt (IZ22346)
    code
    #%NASL_MIN_LEVEL 80502
    #
    # (C) Tenable Network Security, Inc.
    #
    # The text in the description was extracted from AIX Security
    # Advisory errpt_advisory.asc.
    #
    
    include("compat.inc");
    
    if (description)
    {
      script_id(63767);
      script_version("1.3");
      script_cvs_date("Date: 2019/09/16 14:12:49");
    
      script_cve_id("CVE-2008-2514");
    
      script_name(english:"AIX 5.3 TL 0 : errpt (IZ22346)");
      script_summary(english:"Check for APAR IZ22346");
    
      script_set_attribute(
        attribute:"synopsis", 
        value:"The remote AIX host is missing a security patch."
      );
      script_set_attribute(
        attribute:"description", 
        value:
    "The errpt command contains a buffer which can overflow. A local
    attacker may exploit this overflow to execute arbitrary code with root
    privileges because the command is setuid root.
    
    The following files are vulnerable :
    
    /usr/bin/errpt."
      );
      script_set_attribute(
        attribute:"see_also",
        value:"http://aix.software.ibm.com/aix/efixes/security/errpt_advisory.asc"
      );
      script_set_attribute(
        attribute:"solution", 
        value:"Install the appropriate interim fix."
      );
      script_set_cvss_base_vector("CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P");
      script_cwe_id(119);
    
      script_set_attribute(attribute:"plugin_type", value:"local");
      script_set_attribute(attribute:"cpe", value:"cpe:/o:ibm:aix:5.3");
    
      script_set_attribute(attribute:"vuln_publication_date", value:"2008/05/21");
      script_set_attribute(attribute:"patch_publication_date", value:"2008/05/21");
      script_set_attribute(attribute:"plugin_publication_date", value:"2013/01/24");
      script_end_attributes();
    
      script_category(ACT_GATHER_INFO);
      script_copyright(english:"This script is Copyright (C) 2013-2019 Tenable Network Security, Inc.");
      script_family(english:"AIX Local Security Checks");
    
      script_dependencies("ssh_get_info.nasl");
      script_require_keys("Host/AIX/lslpp", "Host/local_checks_enabled", "Host/AIX/version");
    
      exit(0);
    }
    
    
    
    include("audit.inc");
    include("global_settings.inc");
    include("aix.inc");
    include("misc_func.inc");
    
    if ( ! get_kb_item("Host/local_checks_enabled") ) audit(AUDIT_LOCAL_CHECKS_NOT_ENABLED);
    if ( ! get_kb_item("Host/AIX/version") ) audit(AUDIT_OS_NOT, "AIX");
    if ( ! get_kb_item("Host/AIX/lslpp") ) audit(AUDIT_PACKAGE_LIST_MISSING);
    
    if ( get_kb_item("Host/AIX/emgr_failure" ) ) exit(0, "This iFix check is disabled because : "+get_kb_item("Host/AIX/emgr_failure") );
    
    flag = 0;
    
    if (aix_check_ifix(release:"5.3", ml:"00", patch:"IZ22346_05", package:"aid", minfilesetver:"5.3.0.50", maxfilesetver:"5.3.0.53") < 0) flag++;
    if (aix_check_ifix(release:"5.3", ml:"00", patch:"IZ22346_05", package:"aid", minfilesetver:"5.3.0.60", maxfilesetver:"5.3.0.65") < 0) flag++;
    if (aix_check_ifix(release:"5.3", ml:"00", patch:"IZ22346_06", package:"aid", minfilesetver:"5.3.0.50", maxfilesetver:"5.3.0.53") < 0) flag++;
    if (aix_check_ifix(release:"5.3", ml:"00", patch:"IZ22346_06", package:"aid", minfilesetver:"5.3.0.60", maxfilesetver:"5.3.0.65") < 0) flag++;
    
    if (flag)
    {
      if (report_verbosity > 0) security_warning(port:0, extra:aix_report_get());
      else security_warning(0);
      exit(0);
    }
    else audit(AUDIT_HOST_NOT, "affected");
    
  • NASL familyAIX Local Security Checks
    NASL idAIX_IZ21494.NASL
    descriptionThe errpt command contains a buffer which can overflow. A local attacker may exploit this overflow to execute arbitrary code with root privileges because the command is setuid root. The following files are vulnerable : /usr/bin/errpt.
    last seen2020-06-01
    modified2020-06-02
    plugin id63765
    published2013-01-24
    reporterThis script is Copyright (C) 2013-2019 Tenable Network Security, Inc.
    sourcehttps://www.tenable.com/plugins/nessus/63765
    titleAIX 5.3 TL 8 : errpt (IZ21494)
  • NASL familyAIX Local Security Checks
    NASL idAIX_IZ19905.NASL
    descriptionThe errpt command contains a buffer which can overflow. A local attacker may exploit this overflow to execute arbitrary code with root privileges because the command is setuid root. The following files are vulnerable : /usr/bin/errpt.
    last seen2020-06-01
    modified2020-06-02
    plugin id63763
    published2013-01-24
    reporterThis script is Copyright (C) 2013-2019 Tenable Network Security, Inc.
    sourcehttps://www.tenable.com/plugins/nessus/63763
    titleAIX 5.2 TL 0 : errpt (IZ19905)
  • NASL familyAIX Local Security Checks
    NASL idAIX_IZ22347.NASL
    descriptionThe errpt command contains a buffer which can overflow. A local attacker may exploit this overflow to execute arbitrary code with root privileges because the command is setuid root. The following files are vulnerable : /usr/bin/errpt.
    last seen2020-06-01
    modified2020-06-02
    plugin id63768
    published2013-01-24
    reporterThis script is Copyright (C) 2013-2019 Tenable Network Security, Inc.
    sourcehttps://www.tenable.com/plugins/nessus/63768
    titleAIX 5.3 TL 7 : errpt (IZ22347)

Oval

accepted2008-07-28T04:00:18.459-04:00
classvulnerability
contributors
nameMichael Wood
organizationHewlett-Packard
definition_extensions
  • commentIBM AIX 5200-10 is installed
    ovaloval:org.mitre.oval:def:5076
  • commentIBM AIX 5300-08 is installed
    ovaloval:org.mitre.oval:def:5293
  • commentIBM AIX 5.3 is installed
    ovaloval:org.mitre.oval:def:5325
  • commentIBM AIX 6.1 is installed
    ovaloval:org.mitre.oval:def:5267
descriptionBuffer overflow in errpt in IBM AIX 5.2, 5.3, and 6.1 allows local users to gain privileges via unknown attack vectors.
familyunix
idoval:org.mitre.oval:def:5629
statusaccepted
submitted2008-06-12T15:10:44.000-05:00
titleIBM AIX Buffer Overflow in errpt Command May Let Local Users Gain Elevated Privileges
version45