CVE-2005-4467 - PHPGedView Multiple Remote Script Code Execution Vulnerabilities

Publication

2005-12-22

Last modification

2018-10-19

Summary

Directory traversal vulnerability in help_text_vars.php in PHPGedView 3.3.7 and earlier allows remote attackers to read and include arbitrary files via a .. (dot dot) in the PGV_BASE_DIRECTORY parameter.

Risk level (CVSS AV:N/AC:L/Au:N/C:P/I:N/A:N)

Medium

5.0

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

Vendor Product Versions
Phpgedview Phpgedview  3.3.7 , 2.65 , 2.61.1 , 2.65.1 , 2.65Beta5 , 2.61 , 2.65.2 , 2.52.3 , 2.60