CVE-2005-4461 - Beehive Forum Index.PHP SQL Injection Vulnerability

Publication

2005-12-21

Last modification

2018-10-19

Summary

SQL injection vulnerability in index.php in Beehive Forum 0.6.2 and earlier allows remote attackers to execute arbitrary SQL commands via the user_sess parameter.

Description

Beehive Forum is prone to an SQL-injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input. Successful exploitation can allow an attacker to bypass authentication and gain administrative access to a site. Other attacks may also be possible. Beehive Forum 0.6.2 is reported to be vulnerable.

Solution

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: info@vumetric.com <mailto:info@vumetric.com>.

Exploit

An exploit is not required. The following proof of concept examples are available: http://www.example.com/beehive/index.php?user_sess=k http://www.example.com/beehive/index.php?user_sess=1+MYFORUM

Risk level (CVSS AV:N/AC:L/Au:N/C:P/I:P/A:P)

High

7.5

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

Vendor Product Versions
Beehive Forum Beehive Forum  0.3 , 0.6Rc1 , 0.6Rc2 , 0.5 , 0.4 , 0.1.1 , 0.1 , 0.2 , 0.3.1 , 0.6.2