Critical

CVE-2004-0290 - Unspecified vulnerability in Freeform Interactive Purge Jihad

Publication: 2004-11-23
Summary

Buffer overflow in Purge Jihad 2.0.1 and earlier allows remote game servers to execute arbitrary code via an information packet that contains large (1) battle type and (2) map name fields.

Risk level (CVSS 10)

Critical

10.0

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

  • Freeform Interactive Purge 1.4.7
  • Freeform Interactive Purge Jihad 2.0.1