High

CVE-2004-0224 - Unspecified vulnerability in multiple products

Publication: 2004-04-15
Summary

Multiple buffer overflows in (1) iso2022jp.c or (2) shiftjis.c for Courier-IMAP before 3.0.0, Courier before 0.45, and SqWebMail before 4.0.0 may allow remote attackers to execute arbitrary code "when Unicode character is out of BMP range."

Risk level (CVSS 7.5)

High

7.5

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

  • Double Precision Incorporated Courier MTA 0.43
  • Double Precision Incorporated Courier MTA 0.43.1
  • Double Precision Incorporated Courier MTA 0.43.2
  • Double Precision Incorporated Courier MTA 0.44
  • Double Precision Incorporated Courier MTA 0.44.2
  • Gentoo Linux 1.4
  • Gentoo Linux 1.4
  • Gentoo Linux 1.4
  • Gentoo Linux 1.4
  • Double Precision Incorporated Sqwebmail 3.6_.0
  • Inter7 Courier-imap 1.6
  • Inter7 Courier-imap 1.7
  • Inter7 Courier-imap 2.0.0
  • Inter7 Courier-imap 2.1
  • Inter7 Courier-imap 2.1.1
  • Inter7 Courier-imap 2.1.2
  • Inter7 Courier-imap 2.2.0
  • Inter7 Courier-imap 2.2.1
  • Double Precision Incorporated Sqwebmail 3.5.2
  • Double Precision Incorporated Sqwebmail 3.5.3
  • Double Precision Incorporated Sqwebmail 3.6.1
  • Double Precision Incorporated Sqwebmail 3.6.2