Moderate

CVE-2004-0179 - Unspecified vulnerability in multiple products

Publication: 2004-06-01
Summary

Multiple format string vulnerabilities in (1) neon 0.24.4 and earlier, and other products that use neon including (2) Cadaver, (3) Subversion, and (4) OpenOffice, allow remote malicious WebDAV servers to execute arbitrary code.

Risk level (CVSS 5.1)

Moderate

5.1

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

  • Cadaver Cadaver Webdav Client 0.20.0
  • Subversion Subversion
  • Cadaver Cadaver Webdav Client 0.20.2
  • Cadaver Cadaver Webdav Client 0.20.3
  • Cadaver Cadaver Webdav Client 0.20.4
  • Cadaver Cadaver Webdav Client 0.20.5
  • Cadaver Cadaver Webdav Client 0.21.0
  • Cadaver Cadaver Webdav Client 0.22.0
  • Cadaver Cadaver Webdav Client 0.22.1
  • Neon Neon Client Library 0.19.3
  • Neon Neon Client Library 0.23
  • Neon Neon Client Library 0.23.1
  • Neon Neon Client Library 0.23.2
  • Cadaver Cadaver Webdav Client 0.20.1
  • Neon Neon Client Library 0.23.4
  • Neon Neon Client Library 0.23.5
  • Neon Neon Client Library 0.23.6
  • Neon Neon Client Library 0.23.7
  • Neon Neon Client Library 0.23.8
  • Neon Neon Client Library 0.24
  • Neon Neon Client Library 0.24.1
  • Neon Neon Client Library 0.24.2
  • Neon Neon Client Library 0.24.3
  • Neon Neon Client Library 0.24.4
  • Openoffice Openoffice 1.1.2
  • Neon Neon Client Library 0.23.3