Moderate

CVE-2004-0165 - Unspecified vulnerability in Apple MAC OS X Server

Publication: 2004-03-15
Summary

Format string vulnerability in Point-to-Point Protocol (PPP) daemon (pppd) 2.4.0 for Mac OS X 10.3.2 and earlier allows remote attackers to read arbitrary pppd process data, including PAP or CHAP authentication credentials, to gain privileges.

Risk level (CVSS 5)

Moderate

5.0

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

  • Apple MAC OS X Server 10.1
  • Apple MAC OS X 10.1
  • Apple MAC OS X Server 10.1.1
  • Apple MAC OS X 10.1.1
  • Apple MAC OS X Server 10.1.2
  • Apple MAC OS X 10.1.2
  • Apple MAC OS X Server 10.1.3
  • Apple MAC OS X 10.1.3
  • Apple MAC OS X Server 10.1.4
  • Apple MAC OS X 10.1.4
  • Apple MAC OS X Server 10.1.5
  • Apple MAC OS X 10.1.5
  • Apple MAC OS X Server 10.2
  • Apple MAC OS X 10.2
  • Apple MAC OS X Server 10.2.1
  • Apple MAC OS X 10.2.1
  • Apple MAC OS X Server 10.2.2
  • Apple MAC OS X 10.2.2
  • Apple MAC OS X Server 10.2.3
  • Apple MAC OS X 10.2.3
  • Apple MAC OS X 10.2.4
  • Apple MAC OS X Server 10.2.4
  • Apple MAC OS X 10.2.5
  • Apple MAC OS X Server 10.2.5
  • Apple MAC OS X Server 10.2.6
  • Apple MAC OS X 10.2.6
  • Apple MAC OS X Server 10.2.7
  • Apple MAC OS X 10.2.7
  • Apple MAC OS X Server 10.2.8
  • Apple MAC OS X 10.2.8
  • Apple MAC OS X 10.3
  • Apple MAC OS X Server 10.3
  • Apple MAC OS X 10.3.1
  • Apple MAC OS X Server 10.3.1
  • Apple MAC OS X 10.3.2
  • Apple MAC OS X Server 10.3.2