High

CVE-2003-0204 - Unspecified vulnerability in KDE

Publication: 2003-05-05
Summary

KDE 2 and KDE 3.1.1 and earlier 3.x versions allows attackers to execute arbitrary commands via (1) PostScript (PS) or (2) PDF files, related to missing -dPARANOIDSAFER and -dSAFER arguments when using the kghostview Ghostscript viewer.

Risk level (CVSS 7.5)

High

7.5

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

  • KDE KDE 2.0
  • KDE KDE 2.0.1
  • KDE KDE 2.1
  • KDE KDE 2.1.1
  • KDE KDE 2.1.2
  • KDE KDE 2.2
  • KDE KDE 2.2.1
  • KDE KDE 2.2.2
  • KDE KDE 3.0
  • KDE KDE 3.0.1
  • KDE KDE 3.0.5a
  • KDE KDE 3.0.3a
  • KDE KDE 3.0.2
  • KDE KDE 3.0.3
  • KDE KDE 3.0.4
  • KDE KDE 3.0.5
  • KDE KDE 3.1
  • KDE KDE 3.1.1