Critical

CVE-2003-0095 - Buffer Errors vulnerability in Oracle Database Server/8I/9I

Publication: 2003-03-03
Summary

Buffer overflow in ORACLE.EXE for Oracle Database Server 9i, 8i, 8.1.7, and 8.0.6 allows remote attackers to execute arbitrary code via a long username that is provided during login, as exploitable through client applications that perform their own authentication, as demonstrated using LOADPSP.

Classification
CWE-119: Buffer Errors

Risk level (CVSS 10)

Critical

10.0

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

  • Oracle Database Server 8.0.6
  • Oracle Oracle8i 8.1.7
  • Oracle Oracle8i 8.1.7.1
  • Oracle Oracle9i 9.0
  • Oracle Oracle9i 9.0.1
  • Oracle Oracle9i 9.0.1.2
  • Oracle Oracle9i 9.0.1.3
  • Oracle Oracle9i 9.0.2
  • Oracle Database Server 9.2.1
  • Oracle Database Server 9.2.2